SSD not recognized by Sandisk Dashboard 1.4.1 -still!

I have just installed a new Sandisk Plus 240Gb SSD running Windows Vista Business 32 bit and the latest SSD Dashboard V1.4.1, and it does not recognize my SSD at all. There is a secondary mechanical SATA drive on the same controller. I have checked and Vista reports the SSD drive as a SCSI device. (I have read in older psotings that OS identifying as SCSI is a problem for Dashboard that was supposed to be fixed long ago). There were no BIOS options in my ageing motherboard to change SATA settings.

Is there any way I can get the Dashboard to recognize the drive?

My reason is that my understanding is that Vista does no support TRIM, so I was hoping to manually TRIM the SSD regularly using the Sandisk Dashboard. 

Alternatively, does anyone know of another way to implement TRIM on Windows Vista?

I would think the drive would become pretty useless in speed over time (negating the whole point of the SSD), without an option to TRIM.

Many thanks


TRIM is an Operating System feature and Windows Vista doesn’t support TRIM natively. You can manually enable TRIM using third party software or using the command line.

Open Elevated Command Prompt:

Type fsutil behavior set disabledeletenotify 0

After doing above, please confirm TRIM is enabled using the following command:

fsutil behavior query disabledeletenotify

Results explained below:
DisableDeleteNotify = 1 (Windows TRIM commands are disabled)
DisableDeleteNotify = 0 (Windows TRIM commands are enabled)

If this doesn’t work, SanDisk SSDs I believe does come with Garbage Collection which also works almost the same way. Either you can update OS from Vista to Windows 7 or above or probably forget about TRIM and rely on Garbage Collection.  

I hope that helps.


1 Like

Many thanks for that response. I was aware Vista doesn’t support TRIM and that was why I was trying (hoping) to use Sandisk Dashboard to run its version of trim manually. But the system BIOS on my old motherboard reports only a SCSI drive to Vista and Dashboard still doesn’t have a solution for that apparently. (they’ve been asking for this to be fixed for over a year in other posts)

I will give those commands a try when I log in next (remote machine), but if all else fails I’ll rely on inbuilt SSD garbage collection and occasional trim using a Live CD of Linux which, I eventually discovered, can be configured to trim NTFS partitions using the latest version of ntfs-3g and fuse components. I tried this on another system and it does in fact trim the NTFS partition. :slight_smile: