SanDisk Extreme USB 3.0 64GB Flash Drive - slow performance

Just bought an Extreme USB 3.0 Flash Drive 64GB and copied some 3.6 GB from my Win7 PC using a USB 3.0 slot.

Felt somewhat slow, so I used H2testw to get an “independent” oppinion:

Write speed: 59 MB/s

Read speed: 72 MB/s

After 6 GB the dongle disconnected an Win aksed me to fix the drive.

Somewhat disappoining for a stick that comes at double the price of a std. USB3 stick.

Any advice?

Many thanks!


forgot to say:

package says:

“up to 245 MB/s read speed” / “190 MB/s write speed”

… far, far away from my experience… (see post above)

any advice highly appreciated!

“up to” is usually in ideal circumstances.  Nothing else running on the machine, very efficient OS, no security  apps running, lots of RAM, ligntning fast processor, perfect power, perfect room temp, etc. etc.  Obviously one or more of those items is effecting your speeds.  Security apps can play a big part of it as can dirty contacts.

Thanks for your quick reply, Ed!

You seem to spend quite some time here answering questions and helping people fixing problems - I truly believe we all highly appreciate this!

Back to my topic: I did suspend my virus/security SW during my tests. I watched task/mgr-resource/monitor for disk activities and there seemed to be just the test pgm accessing the drive - appart from the usual system monitoring.

Did this with both h2testw and ATTO (tried to attach a hardcopy but this reply box doesn’t seem to allow).

Still I feel somewhat disappointed with the throughput.

In the end the package in the store didn’t tell me to buy a Cray supercomputer to reach the specs…



In the end the package in the store didn’t tell me to buy a Cray supercomputer to reach the specs…

ah hah!!  You’ve pin pointed the problem.  Thank you.  :smileyvery-happy:

But I agree your numbers seem low compared to the maximum possible.  Maybe someone else has better ideas.

again, thanks for the quick reply, Ed!

The problem might be related to the type of PC I’m using.

Though it supports USB 3, the internal disk data rate when copying files from/to it seems not to go above 110 MB/s.

I’m using an ASUS Notebook U53Jc, with i5 M460 processor at 2.53 GHz and 4GB RAM.

Internal Drive HW says ST 9500 325 AS.

Maybe too far from Cray?

the thing that really bothers me, however, is that the stick every now and then (every ~2-5 mins) disconnects and reconnects.

any explanation - or cure for this?

Hi Scrambler, i just bought a sandisk extreme and i just opened it. Having very slow speeds as u are. read : 70mb/s and write: 45-50mb/s. I am very very disappointed with the product.

do you get any of those erratical dis-/reconnects, too?

nope not any of those…crystal mark shows 240mb/s speed. But i cannot see them in actual file transfer. Tried all possiblities…no fix yet.

What OS are you using ?

And if Windows are the flash drive’s properties set to Performance or Safe Removal?

Asus has a program “Power4Gear Hybrid”. If this is on your system then go to advanced settings,usb,selective suspend and disable it on both Battery and Plugged in. Suspend will stop power to a port when it’s inactive. Hope this helps

I also own a Extreme 3.0 64gb and got great readings from Atto.  Your readings are very low compared to what I was getting. R/265 W/174.  Maybe run a R/W test on another system. Usb device tree viewer will show you all usb devices, their respective speeds (i.e. High speed super speed,etc) and 2.0 or 3.0 port. Hope this helps

I’m using Win7 Home Premium SP1

they’re set for performance - but to my understanding this just triggers the write cash, right?

So, it should not make a difference for big, e.g. 8GB files…

Btw, I had to reformat the drive to exFAT (from FAT32) since I’m using it for big data files.

But my benchmark tests did not show any difference before and after.

Yes, I found “ASUS Power4Gear”. I probably never activated it before but did now and switched hard drive tomeout to never.

Let’s see if it makes a change.

Many thanks for the hint!

USB device tree viewer lists the drive as a USB 3.0 mass storage device and says:

wSpeedsSupported         : 0x0E (Full-Speed, High-Speed, SuperSpeed)

any other attributes I should look at?

Open device tree and then plug in your usb. Where it shows your connection ( I believe it’s red and blue) you should see an “SS” for super speed. You may have a Rotten Flash Drive otherwise

I did some rummaging around and found that an agressive anti virus could result in sub par preformance. Try disabling anti virus and run speed test.