SanDisk Extreme Pro CZ88 128GB

I am getting very slow read write speeds, nothing like was advertised.  I am using a 3.0 USB and just taking the drive out of the package. 

Here is a link of the speed test I did.


So anyone ?

Hi Mate

I have the same problem with the same flush drive, new just purchased. If you still have it - check it with CrystalDiskInfo, mine have shown 0% health left, I also checked with HD Santinel PRO with the same result and after this I run speed tests, which were bad as yours (a bit better, but still):

Sequential Read : 44.557 MB/s
Sequential Write : 44.881 MB/s
Random Read 512KB : 42.186 MB/s
Random Write 512KB : 39.549 MB/s
Random Read 4KB (QD=1) : 7.378 MB/s [1801.3 IOPS]
Random Write 4KB (QD=1) : 9.854 MB/s [2405.8 IOPS]
Random Read 4KB (QD=32) : 8.271 MB/s [2019.4 IOPS]
Random Write 4KB (QD=32) : 9.922 MB/s [2422.4 IOPS]

Test : 100 MB [N: 0.0% (0.0/119.2 GB)] (x1)

equential Read : 44.533 MB/s
Sequential Write : 44.915 MB/s
Random Read 512KB : 42.315 MB/s
Random Write 512KB : 36.576 MB/s
Random Read 4KB (QD=1) : 6.705 MB/s [1637.0 IOPS]
Random Write 4KB (QD=1) : 6.864 MB/s [1675.8 IOPS]
Random Read 4KB (QD=32) : 6.941 MB/s [1694.6 IOPS]
Random Write 4KB (QD=32) : 6.989 MB/s [1706.2 IOPS]

Test : 1000 MB [N: 0.0% (0.0/119.2 GB)] (x1)

And now I just run test on my older, already repaired for bad sectors, Patriot 64GB Stellar OTG drive:

Sequential Read :   115.646 MB/s
Sequential Write :    55.620 MB/s
Random Read 512KB :   119.137 MB/s
Random Write 512KB :    24.142 MB/s
Random Read 4KB (QD=1) :     4.557 MB/s [  1112.6 IOPS]
Random Write 4KB (QD=1) :     1.185 MB/s [   289.2 IOPS]

Random Read 4KB (QD=32) :     5.420 MB/s [  1323.3 IOPS]
Random Write 4KB (QD=32) :     1.941 MB/s [   474.0 IOPS]

  Test : 100 MB [N: 0.2% (0.1/57.7 GB)] (x1)

And external 8Tb WD USB 3.0 Hard Drive

Sequential Read : 167.104 MB/s
Sequential Write : 164.122 MB/s
Random Read 512KB : 39.738 MB/s
Random Write 512KB : 76.386 MB/s
Random Read 4KB (QD=1) : 0.369 MB/s [90.2 IOPS]
Random Write 4KB (QD=1) : 1.302 MB/s [317.8 IOPS]
Random Read 4KB (QD=32) : 0.621 MB/s [151.6 IOPS]
Random Write 4KB (QD=32) : 1.389 MB/s [339.2 IOPS]

Test : 1000 MB [O: 31.7% (2362.1/7452.0 GB)] (x1)

  All tests are run with the same parameters, some with sample of 1000 MB and some with 100 MB.

SanDisk should beat all those items with ease, but it is not. However mine was mechanically falling. I reordered another one, will post here new tests when I get it.

So, nothing is wrong with my PC, it is something not right with SanDisk.

Lets hope someone will respond

Just curious, are you sure the place you are ordering from is not selling counterfeit drives?  Have you tried buying from local major retailer?

Thanks for the interest in this mess.

I got it from Staples. Getting exchange item today or tomorrow, will post drive quality and speed tests once own it.

Major update, hence new post.

Got a replacement. This time SMART is OK, which is good.
Here are the test results, plenty.

CrystalDiskMark (64bit) FAT32

Sequential Read : 267.196 MB/s
Sequential Write : 242.365 MB/s
Random Read 512KB : 202.286 MB/s
Random Write 512KB : 26.694 MB/s
Random Read 4KB (QD=1) : 10.794 MB/s [2635.2 IOPS]
Random Write 4KB (QD=1) : 11.215 MB/s [2738.0 IOPS]
Random Read 4KB (QD=32) : 10.296 MB/s [2513.7 IOPS]
Random Write 4KB (QD=32) : 11.650 MB/s [2844.2 IOPS]
Test : 100 MB [N: 0.0% (0.0/119.2 GB)] (x1)

Null ZEROs 00000
Sequential Read : 267.196 MB/s
Sequential Write : 241.806 MB/s
Random Read 512KB : 202.556 MB/s
Random Write 512KB : 27.187 MB/s
Random Read 4KB (QD=1) : 10.806 MB/s [2638.1 IOPS]
Random Write 4KB (QD=1) : 11.152 MB/s [2722.7 IOPS]
Random Read 4KB (QD=32) : 10.272 MB/s [2507.8 IOPS]
Random Write 4KB (QD=32) : 11.688 MB/s [2853.4 IOPS]

Test : 100 MB [N: 0.0% (0.0/119.2 GB)] (x1) <0Fill>

Null ONEs 11111
Sequential Read : 267.153 MB/s
Sequential Write : 242.445 MB/s
Random Read 512KB : 202.860 MB/s
Random Write 512KB : 27.450 MB/s
Random Read 4KB (QD=1) : 10.813 MB/s [2640.0 IOPS]
Random Write 4KB (QD=1) : 11.165 MB/s [2725.8 IOPS]
Random Read 4KB (QD=32) : 10.259 MB/s [2504.7 IOPS]
Random Write 4KB (QD=32) : 11.668 MB/s [2848.7 IOPS]

Test : 100 MB [N: 0.0% (0.0/119.2 GB)] (x1) <1Fill>

Random Large
Sequential Read : 268.007 MB/s
Sequential Write : 249.334 MB/s
Random Read 512KB : 201.951 MB/s
Random Write 512KB : 27.324 MB/s
Random Read 4KB (QD=1) : 10.708 MB/s [2614.2 IOPS]
Random Write 4KB (QD=1) : 10.635 MB/s [2596.5 IOPS]
Random Read 4KB (QD=32) : 8.733 MB/s [2132.0 IOPS]
Random Write 4KB (QD=32) : 10.705 MB/s [2613.6 IOPS]

Test : 1000 MB [N: 0.0% (0.0/119.2 GB)] (x1)

NTFS Random small

Sequential Read : 267.026 MB/s
Sequential Write : 205.502 MB/s
Random Read 512KB : 202.051 MB/s
Random Write 512KB : 27.892 MB/s
Random Read 4KB (QD=1) : 10.760 MB/s [2626.9 IOPS]
Random Write 4KB (QD=1) : 4.230 MB/s [1032.6 IOPS]
Random Read 4KB (QD=32) : 10.551 MB/s [2576.0 IOPS]
Random Write 4KB (QD=32) : 4.573 MB/s [1116.5 IOPS]

Test : 100 MB [N: 0.1% (0.1/119.2 GB)] (x1)

EXFAT Random small

Sequential Read : 267.026 MB/s
Sequential Write : 223.747 MB/s
Random Read 512KB : 194.019 MB/s
Random Write 512KB : 30.987 MB/s
Random Read 4KB (QD=1) : 10.786 MB/s [2633.4 IOPS]
Random Write 4KB (QD=1) : 3.912 MB/s [955.1 IOPS]
Random Read 4KB (QD=32) : 11.195 MB/s [2733.2 IOPS]
Random Write 4KB (QD=32) : 3.855 MB/s [941.1 IOPS]

Test : 100 MB [N: 0.0% (0.0/119.2 GB)] (x1)

And now I have to decide, which format to keep EXFAT or NTFS?
Any ideas, anyone?
P.S. I am planning to use it as transport drive with all file sizes, could be thousands of small files or bunch of huge files?

I recommend:

  1.  not formatting a working drive

2.  not formatting a working flash drive as a hard drive

exFAT handles large and small files and has no journeling overhead. 

Thanks for advising here.

Drive was preformatted as FAT32 from the store, so I had to reformat it anyway, I did not play with formatting just to check the drive speed. I tried to format to EXFAT right away, but HP tool (SanDisk recommended) did not provide this option, only NTFS and FAT32, AOMEI also did not provided EXFAT, next I tried from PC Control Panel to Disk Management, drive was formatted as EXFAT, but it disappeared from Devices, strange, so I reformatted back to NTFS and was able to format to EXFAT (current format) using Right Click Format option in My PC (My Computer) Explorer Window, this EXFAT was completely recognized by Windows.

Have you see here at forum other people posting benchmarks? I need something to compare to. Or can you differentiate my model SDCZ88-128G- A46 and SDCZ88-128G- G46. G46 has a lot of Amazon reviews with speed tests, it seems like the same drive, but without password and encription protection (I don’t care about this). Am I correct?

Thanks for helping.

Forget to add a question, too late to edit.

Temperature. Is there somewhere complete specs for the drive including operating temperature, my tools shows that this drive easily going to 50 C - 60 C range, how bad it is for the internal parts? At the same time Drive is still cool to touch.

Really strange.

EDIT. Found this

Environmental Parameters
  Max Operating Temperature:   113 °F (45 C)
  Min Operating Temperature:  

32 °F (0 C)

But this not exactly what I need. How hot internally this drive can safely be, this is the question.

Flash drives larger than 32GB are formated as exFAT at the factory.  And Windows supports formatting large drives as exFAT, no extra tools needed. 


I am not arguing here about how factory format those drives, but the first, mulfanctined drive was also formatted FAT32 when I opened it.

How about the temperature or drive data sheet, is it possible to find? If not, Monday I will contact Support throught  the Chat. I just want to be safe with using drive a lot.

Thanks for help.

I have found another peice of information:

Capacity 128 GB
Read/Write Speed Read: Up to 260 MB/s
Write: Up to 240 MB/s
Operating Temperature 32 to 113°F / 0 to 45°C
Storage Temperature 14 to 158°F / -10 to 70°C
Compatibility USB 3.0 and USB 2.0
Dimensions 0.45 x 0.84 x 2.79" / 11.0 x 21.0 x 71.0 mm
Weight Not specified by manufacturer

Basically, to the best of my knowledge, upper parameter for storage could be as well the limit for the internal temperature. Question is answered. The only strange part that when drive is idle its temperature is 50 C, something is not right, will check with other tools, but HD Santinel never lied before, very relaible program.

Will keep forum posted.

You’re missing a point.  If the factory manufactures these drives as exFAT and you’re buying them as FAT32 something is wrong!  And we have Staples stores here and they are good people so I’m not accusing them of wrong doing.  But IMO there is something wrong with your senario.

I guess that Sandisk changed formatting rules, it is not only Staples - "Inexplicably, it comes formatted FAT32" sells those drives in FAT32 format as well, check review by FRED 7/18/2015.

When I checked speed of both drives, the highest was in FAT32, so I guess, SanDisk choose this way to support advertized speed right out of the box - very strong selling point.

Thank you for the update kisianik.  I was not aware they changed their format policy.

Update regarding temperature.

Just finish chatting with tech support. They have no clue about SMART temps:

"I asked:

This is all I was able to find:Operating Temperature 32 to 113°F / 0 to 45°C
Storage Temperature 14 to 158°F / -10 to 70°C
I asked:

As hard discs, flush drives should have similar upper limit for temps at which there is a system, harware failure. Is it 70 C, or higher?
John S (chat response).: Operating Temperature: 32° - 95° F (0° - 35 °C)

That is what posted on Sandisk site:

SanDisk USB drives are designed using the Safety of Information Technology Equipment, IEC 60950-1 as guidance. Many countries, including the United States, Canada, Europe, Australia and New Zealand, have adopted this safety standard.

In accordance with this guidance, SanDisk USB drives are tested to operate within acceptable ambient temperature ranges (0º C and 25º C). Our drives are also tested in an extended temperate range and will operate in environments between 25º and 45º C.

In environments that are on the higher end of the tested temperature range, such as 25 º C - 45º C, it is normal for the temperature of your flash drive to increase. The exterior of the drive functions as a cooling surface that transfers heat from inside the drive to the cooler air outside. If the temperature of the ambient environment is high or if the temperature of your host devices (such as your laptop which can also generate heat) is high, the drive will release heat in a less efficient manner. It is normal for the drive to be warmer in these circumstances than it would be if the ambient environment or host device was cooler.

So tech support need to go back to school and learn at least the official Sandisk statements before providing any suggestions (was suggested to RMA drive). What a shame.

If I will find more relevant info, I will update.

Another update just found here


So, as everyone can see, those flush drives are actually warming up a lot. And according to support tech “it is not normal”, give me a break.

@ed_p wrote:

I recommend:


  1.  not formatting a working drive

2.  not formatting a working flash drive as a hard drive

Why do you recommend not formatting?

Please provide (preferable technical) reasons not to do so. Thank you


I do it because:

1.  The usb drives are formatted to be as fast as possible when they come off the assembly line.  Cluster size and alignment are all tweaked to their best performance values for the drive because that is the goal of the manufacturer.

  1. 90% of users who have reformatted their drives took the defaults their Windows system gave them, which are designed to format a drive as quickly and as easily for all Windows users using all kinds of drives because that is the goal of Microsoft.

  2. Many of the problems posted here are from users who have reformatted their drives.

  3. I have numerous flash drives and I have only once found a need to reformat one. 

I don’t agree, because this particular drive is formatted as FAT32 and as such, does not allow files above 4 GB. Only NTSF and EXFAT allow files above 4GB.

I recently purchased another, competitor’s flush from Corsair, which is also top of the line, and guess what, also fomatted in FAT32 for “compatibility with both MAC and Windows platforms’” right out of the box. Corsair Voayger GTX 128 GB write speed is below 200 MB/s, but read speed is above 400 MB/s for large files, however, for small files Corsair has at least 50% faster write speed than Sundisk. And this one was reformatted as NTFS for full Windows TRIM support (this Corsair is true PSSD).

I promised to come back with temperature comparison between Sandisk and Corsair. Corsair temp sensor in SMARt shows correct temperature, way below 40C under load.

So I guess Sandisk produced not fully cooked SMART support for its top of the line flush drive, no comments here.