Sandisk Extreme 64GB - Slower write speeds after system format

I have problem with Sandisk Extreme 64GB USB 3.0 Pendrive, I formated it in Windows 7 to exFAT (full format) and now write speeds are slower than before.

How can I reformat it exaclty same like it was by Sandisk ?

I find that information

drive you lose the custom logical block offset which was put in to provide (sometimes radically) improved transfer speeds.

So I need to restore the original file system scheme. Help Sandisk please.

"I formated it in Windows 7 to exFAT (full format)"

Why did you format it?  Why not leave it the way it was?

Because by default was FAT32, and I need exFAT for larger one file size over 4GB.

From CrystalDiskMark Sequential speedsOut of box

Read: 203MB/s

Write: 181MB/s

After format in system :frowning:

Read: 201MB/s

Write: 159MB/s 

I want to get back to previous speeds PLEASE, even with FAT32 file system, I know it’s not very big difference now but it’s slower and I feel that.

Try NTFS.  it doesn’t have the 4GB file limit either.

Nothing help, still slower in write!

BEFORE any format out of box

AFTER format

Thank you for confirming what I have always said.  Don’t reformat a new drive unless you absolutely positively have to, large file sizes being the only example IMO.  I think you’ve gone as far as you can at this point.  If you need 4GB files to fit you have exFAT and NTFS as your options but there is a down side.

You could try enabling the drive caching capability but you have to be very very certain you always Safely Remove any flash drive you use in the machine.

Could You tell me how to get back to previous speeds ?

See if SanDisk will replace the drive.  But you will be back at FAT32 and limited to files 4GB or less.

@petermac wrote:

Could You tell me how to get back to previous speeds ?

I believe that was the “down side” Ed was referring to. You’ve crossed over and burned that bridge.

Sorry I don’t understand what you wrote too much with that bridge sentence :slight_smile: (I’m from Poland)

The expression relates to being able to go back once you have crossed over a wooden bridge.  If you burn the bridge after you cross it you can’t go back.  Commonly used when a person leaves a job to go to another one.  If he insults his old boss and company when leaving chances are he will never be able to go back to it.  If he leaves on good terms the possibility of being rehired is open.


What you talking about:dizzy_face: ? what this have to my problem, I’m looking for real solution advice here to restore factory write speeds!

What factory is set default allocation size for this drive ? Of course I tried with “Restore device defaults” in format nothing help, and I think windows not recognize it correctly.

sandisk does not have a formatting tool for USB drives so I am not sure you are going to be able to get back the exact same offset. My 64GB USB 3 drive is FAT32 128kilobyte allocation size. 

Windows will not do FAT32 in partition larger than 32GB so you would need a third party formatting tool. No guarantee it will work but you can give it a shot. 

What you talking about :dizzy_face: ? what this have to my problem,”

You asked:

Sorry I don’t understand what you wrote too much with that bridge sentence

I tried to explain.

Ed_P - ok no problem :wink: thanks for explain.

I contacted with Sandisk support, told them everything, and they said there is no possible to delete default partition offset, with any format, and I don’t belive in that because I see how write this pendrive now, and how was before format.

Finally they don’t help me :frowning:

Please help me! I bought one of this and formated because had a virus, then I did a test with cristaldiskmark:
Read Speed: 34.24
Write Speed: 29.11

I tried to format it with fat32 with third party applications, and the speed remains the same, how do restore to factory settings? or what can i do?

If you bought it new, new as in from a major retailer vs eBay, then it did not have a virus.  Your AV was giving you a false positive, something Norton does frequently.

There is no way for reformat it back to factory specs.  Any type of formating you do will realign the clusters, create a MBR and create a partition table.  Sorry.

"what can i do?"

You can learn that formating isn’t a cure for everything. :wink:

well i’ve learned that “formating isn’t a cure for everything” but im looking for a solution to my problem,  i just want my USB get closer to the real speeds, after all you’re the expert here, right?