Sandisk Extreme 64GB - Slower write speeds after system format

"you’re the expert here, right?"

:smileyvery-happy: Hardly, but thanks for thinking so.  :smiley:

The initial format is a super floppy format; no MBR, no partition table, is FAT32 and a cluster size that I don’t know.  It probably varies depending on the size of the flash drive.  I know of no app/utility that will recreate that format.  That doesn’t mean one doesn’t exist, just that I don’t know of one.

If you have an app/utility/way to format the drive with different cluster sizes try formating it with different sizes and see if ones are better than others for you.

This will definetely help!

https://docs.google.com/document/d/1FBHLnaJJ1Ev5b90lrNpJ6BUaQFvAFrrUFYErlhtIuLM/edit

Thanks panas.  An interesting read.

i just bought one usb3 sandisk extreme 64GB, at first the read & write speed were like 30 ~ 40 MB/s almost the same on both usb2 and usb3 ports, i thought it was strange i formatted the disk to NTFS quick format, but the speed didnt change,

i solved this problem by updating my motherboard drivers like intel chepset, intel rapid storage, bios others ,

after installing the drivers i restarted my pc, then the speed jumped to read speed around 150 ~ 250 MB/s

write speeds around  ~ 150 MB/s 

i was like whaaaat speed.

i think the problem most of the owners of this sandisk extreme usb3.0 is with drivers, formatting does virtually nothing.

i hope this helps.

What you need to do before you ever format a usb drive is copy down its current structure and information about alignment and such. Then duplicate the structure and alignment using a formatting tool. If you don’t know how to do that, you shouldn’t be reformatting it. 

Regardless, here’s a snapshot of of what the original factory default structure is like of a sandisk extreme usb 3.0 64GB drive

factory default structure

Use something like gparted (http://gparted.org/)) and make 32K block size, align to 32K, start of the partition should be at 32K as well.

If the drive is still slow try doing a full format, not a quick format.

What I’m surprised about is why doesn’t SanDisk just provide a tool that formats your drive to factory condition?

Because there is so little need to format the drives. 

Because there’s no need for people to hold files larger than 4GB on a 64GB drive.  You MUST be daft.

Formatting for files larger than 4GB is the only reason to format the drive.  But NTFS has overhead, namely journelling, and that slows things down.  If small cluster sizes are choosen that doesn’t help either.  And if the Windows system config for USB drives is set to Safety rather than Performance that also doesn’t help.

So you formatted your flash drive to NTFS and now you want to format it back to FAT32?

I had horrible horrible writing speeds close to stalling after a very very nice thrust up until the 1gb mark. And yes my usb3 works fine on my other usb3 devices. I then tried enabling caching, and i WAS sure to remove it correctly. Only trouble was windows froze the device at one point. Could not release it, nor shutdown windows. I even waited 10-15 min to be sure. Now the drive is “broken” ie i NEEDED to reformat it. Hasnt been the same since. anyway kinda seperate problem i guess.

My reason being here is you Ed_P. Although polite you are still being kinda douchebag. I’ve NEVER heard that you are not supposed to format drives of any kind. We have been using it as a basic feature in dos/windows since the floppy drives, wth are you talking about when you say you are not supposed to reformat from stock. Frankly i feel cheated there wasnt a big red sticker on the box of the product warning you of this. I can’t remember if this even came with a manual, but if it did, I read it. I always do, and I certainly don’t remember this written anywhere.

You are blaming PeterMac and Yanos43, basicly saying they did this to themselves.

Are you employed by sandisk or what? or selfproclaimed sandisk guru? I sure hope its the last, because you are bad advertisement sorry

EDIT: and I could not believe this drive got shipped with fat32. It’s 2014 why this **bleep** still exist. Imo reformating to a filesystem that supports 4gb+ files is an absolute must. For me drive is unusable without.

thanks to the last posts by people who came up with constructive replies

:smileyvery-happy:

 

We have been using it as a basic feature in dos/windows since the floppy drives,

 

but then you say

 

It’s 2014

 

Yup, it is 2014, and you can’t buy DOS floppies anymore and your machine is running Windows not DOS but you’re still doing things like it was 1974.  Why should SanDisk change when you haven’t?

 

FAT32 is a format that is compatible across multiple OSs, and multiple devices. People use removable devices in more than their 386 machines now days. Desktop machines, notebooks, ipads, tv, printers, etc.  Thus the use of the FAT32 format today.

 

But the FAT32 format is indeed an old format and people are creating files larger than 740 KB floppies.  So newer, larger drives have an exFAT format but they don’t work in all devices, most TVs for example. 

 

And yes, sometimes one has to reformat a device/drive to resolve a problem.  File size limitation, device corruption, etc.  But doing it for a reason is not the same as doing it because that’s what you have always done with floppies.

 

Whats the trouble, i say SINCE floppy drives. That includes up until 2014 and not just floppies. And with dos/windows i tried to illustrate the long period we have all been doing this. English is not my primary language, but im pretty sure this should be clear enough.

There is no need to degrade me like im a retard running a 386 with dos. In fact my first pc was a 286 with a EGA monitor D:

This is indeed news to me, but i don’t beleive im the only one formating with no hesitation whatsoever.

I guess i did not get the memo about when it became hurtfull to format your drives. Whatever technology they might be built on. Quite the opposite in fact, quite a basic feature in windows too…

Again a warning would have been nice.

:smiley:

English is not my primary language

Your English is just fine. 

There is no need to degrade me like im a retard

That was certainly not my intent.

In fact my first pc was a 286 with a EGA monitor

Yup, and it probably had 640 KB of RAM and a 20 MB hard drive.  Been there, done that. I understand.

This is indeed news to me, but i don’t beleive im the only one formating with no hesitation whatsoever

I understand and I agree but that doesn’t make it right.  Years ago, before antiviruses apps were common, malware could be spread on floppies, so to be safe when inserting a floppy you formatted it.  Quickly and without hesitation.  But things have changed, every new pc has a firewall and antivirus build in, floppies no longer autorun when inserted, and the capacity of the removable drives has grown from 740 K B to 64 GB and more.  Things have changed.  Guess what, so to should the automatic formatting action.

Again a warning would have been nice.

Be honest, would you have read it if one was included?  How many things in this life have you learned from making a mistake?  Fork is wall socket turns out the lights!!  Red wire in oven is HOT!!  Putting car in reverse when going 50 mph is a bad idea!!  Those are things I learned by doing.  Formatting a USB drive without cause is something you have now learned.  It’s how we learn.

Please keep the posts civil and on topic. Personal attacks are prohibited and will not be tolerated. This post will serve as the one and only warning. 

Forum Admin

slotmonsta

Personal attacks are prohibited and will not be tolerated.

 

Relax.  Nobody is attacking or being attacked.  Just two old timers having a discussion.

Hey Ed thanks for levelling with me :wink:

I did learn something today, and I’m the type that remembers stuff so i guess thank you for teaching an old dog some new tricks. Oh how i treasure old memories of playing some of my first pc games on this 286. Duke nukem 1, Golden axe, Alleycat etc D:

I think my device is broken now tho (sandisk extreme 64gb). My computer gets very slow and somewhat unresponsive when it’s plugged in. It was very bad after the unsafe removal, so i just formated and turned of cahing. It’s much better now but still leaves much to be desired concerning transfer speed. But at least it stopped doing that fast burst and then stall. Right now it’s runing at a pathetic 30-40mb/sec. I also have a transcend usb 3.0 stick and that one is working just fine…

Would a low-level format be able to help in any way? getting it back to factory settings or close. Stumbled upon this HDD-LLF-Low-Level-Format-Tool

playing some of my first pc games on this 286. Duke nukem 1

 

Oh yes, I remember Duke Nukem.  Many, many hrs of it.  I wonder if I still have that on a floppy upstairs?  :smileyvery-happy:

 

Would a low-level format be able to help in any way?

 

I honestly don’t know.  But if it doesn’t work you can always reformat.  GD&R  :smileyvery-happy:

 

But before trying the low-level format try reformatting using different blocksizes.  If you’re currently using 8 MB try 4 MB.  If that doesn’t help try 16 MB.  I don’t know what the initial size was, maybe someone with more knowledge than I can step in and give a clue.  And try diskpart rather than the standard Windows format option.  Let us know what you try and how things turn out.

-update-

Checked out that link you posted.  It appears to be for hard drives only.

HDD Low Level Format Tool is a utility for low-level hard disk drive formatting.

So I don’t think it will help with the SanDisk drive.

It’s even in the title “HDD” haha i should have seen that. Will try different block sizes and that program you recomended and write my results here later.

Seems like i dragged this a bit off-topic :slight_smile:

Great success! I formated with diskpart and boom, device is now stable and responsive. Transfer speed got a big boost to a steady 100mb/sec which is a breath of fresh air. Still not monster fast but its stable now and fully functional for my needs. I could not find options to allocate unit size in diskpart, maybe it could get even better?

I had the same issue:

A formerly great performing Sandisk EXTREME Stick 64GB was down to 24MB/s write speed after formatting it to NTFS.

However, how weird is it that SanDisk doesn’t care to provide a Tool to help users store >4GB files

on the most common File System?

Instead we are blamed to have formatted our devices.

(Silly ideas these customers … )

Fact is that SanDisk does not provide adequate tools for aligning partitions / sectors properly.

Something that is well known to be important for drive performance.

Oh, of course that’s something SanDisk support doesn’t tell us.

I was able to fix the problem with HPUSBDisk.exe.
Remember: Don’t blame me, if something goes wrong! It’s your risk if you damage your Sandisk with that tool.