SanDisk Extreme Pro 128GB becoming very slow

I’m an expert computer user, and I’m having trouble getting the proper speed on my SanDisk Extreme Pro 128GB stick.  :(

In summary, I used to be able get >100MB/s write speed into the device, but can now only get 20-30MB/s write speed on the same USB 3.0 port doing the same type of file copy operation under Windows 10 Pro.

This started happening after I ended up using >95% of the device capacity when I tried to copy a very large file over.  :(

I have used this device no more 50-100 times, so I don’t think it’s hitting the P/E cycle limit.  Given that this device does not support TRIM, I tried writing zero to the entire LBA range, and it helped restore the performance a bit initially to >100MB/s, but quickly dropped back down to 20-30MB/s again as I used the device beyond ~20% capacity or so.  :(

I have tried formatting the device with both MBR and GPT parittion tables, as well as shifting the initial GPT partition offset to start at 64MB.  I also tried exFAT (with 1MB allocation unit size) or NTFS (with 64KB allocation unit size).  Even after all these, I’m still getting that poor performance.  :(

I’m wondering if I should RMA this device, or if there’s other tricks that I should have tried but haven’t?
(ie, is there a SanDisk tool for cleaning this USB device to completely reset its FTL state?)



Hi Lawrence, I had the same problem with my Sandisk extreme 64gb on windows 10 home. Write speeds very slow.

I searched all over the internet, tried reformatting, tried using the SD Formatter tool on the Sandisk website, but no luck.

Now today I went into device manager > USB Controllers and uninstalled all of the USB 3.0 Drivers (there were 3).

Then restarted the pc. The drivers were reinstalled immediately by windows, and the write speed of the Sandisk Extreme is now over 100mb/s! Maybe the drivers were corrupt. But now it’s fixed!

Hope this helps.

1 Like

Same here with 128G drive. The worth thing is if you keep some portable app on it, when you try to launch them they just hang.

The advanced bios menus and setup options Kisianik.

supports fast charging of usb connected devices such as a phone ect via a cable by default are turned off in the bios and have to be enabled.

Plus formatting of the drive and the type of format does matter and effects the final speed result .
Daft as it sounds but usb super speed if the option for it exists in the motherboard bios is enabled.
Or any 3.0 or 3.1 device compatibility is enabled.