Sandisk Extreme 900 1.9TB

I don’t see a forum for the new Sandisk 900 series, so Moderator, relocate this post if/as necessary.  

I have an ASUS UX501VW Zenbook (Skylake 6700HQ/Windows 10) that has three USB 3.0 ports and a USB-C /Thunderbolt 3 port.  If I use the USB-C / Thunderbolt port with a special cable (a USB-C connector on one end and a SATA III connector on the other end), both of my Sandisk 480 GB SSDs connect with no problem.  

However, if I use the included USB-C to USB-C cable that comes with the Sandisk Extreme 900, Windows 10 will not recognize the Sandisk 900 drive.  The Sandisk Extreme 900 works fine when using the USB 3.0 ports (and the supplied USB 3.0 type A to USB-C) cable that comes with the unit.  

Any suggestions?  I have tested the Sandisk 900 on two Asus UX501VW Zenbooks with the same result.  Thanks for any suggestions!

Check what kind of USB port the type c port on that computer is. The Extreme 900 is actually 2 SSD drives that are in a RAID. This requires more power than some USB type c ports can provide. If the type c port is a 3.0 only it likely will not work since they do not provide enough power for 2 drives in a RAID. If you have the newer USB 3.1 type C (aka USB 3.1/gen 2) ports it should provide enough power as they can provide up to 100W. I have also read some computer may need driver updates so make sure to check the ASUS website for any driver updates that may be available. 

Here is some more info on the different types of USB ports, is the best online store for shopping Sandisk pendrive of different model.

Wow 9TB.


USB 3.0 connectors capable of 5Gbps (SuperSpeed) are classified as USB 3.1 Gen 1. While the new USB 3.1 connectors, capable of 10Gbps (SuperSpeed+) are classified as USB 3.1 Gen 2. Now Type-C is not automatically linked to USB 3.1 Gen 2 speeds (up to 10Gbps). Some products with the Type-C connector still only supports USB 3.1 Gen 1 speeds (up to 5Gbps).

SanDisk Extreme 900 Portable SSD needs at least 5V @ 2A, 10W for normal operation. USB 3.1 Gen 2 systems should be able to provide that. ASUS UX501VW does include USB Type-C Gen. 2 port. I believe your Zenbook offers what is required to use the drive with Type-C port. So I agree you might need drivers to fix this. Check this out:   

I hope that helps.



Ive got the exact same problem, just got the laptop and USB drive but cant use the high speed of it - the main reason I bout it over the other ones! Any specifics onwhat needs updating would be welcome!



So after a bit of investigating I ahve this fixed so thought id post the answer here in case others have the problem.

Go to and under Utilities get ASUS Thunderbolt firmware Update NVM_v15_TI_v1.5 

Once the firmware was updated for thunderbolt it worked fine, I’m getting approx 400MB/sec on copying alarge 20gb file.

The driver is not true for SSD but for SATA controller on your PC. Windows 10 should have all SATA drivers for AHCI, Legacy, or RAID included in the operating system.

Ask for the information for these interesting things.

first, check the connect of USB port connection. if extreme has 900 then it has 2 SSD drives that are in the RAID. it requires more power to drive the C powers. if the port type is 2 then it will not work. it does not provide enough power and after that check the driver updates.

QuickBooks Support