SanDisk Extreme 240gb performance problem at 4k writes

I just got a brand new SanDisk Extreme 240gb yesterday. Before even initializing the drive I flashed it to the new R211 firmware.
I cloned my windows 7 from my old adata s599 ssd onto the SanDisk and ran some benchmarks with atto.
Im finding constantly that my drive does not show as good of a 4k, 8k, 16k, 32k speeds. In fact im seeing 1/3rd the speed and a much slower climb. the write speeds dont break the 500 mark until the 8192k write test.
I tried ForceTrimas suggested but it didnt improve anything.

My systeam
intel 3770k
asus p8z77-v pro Im connected to the intel z77 sata 6gb controller the asmedia 6gb controller was further cutting the performance in half

in terms of drivers im running the latest drivers on everything. intel chipset, bios, windows7 updates…
I have also tried different sata 3 and 2 cables. 

Surprisingly the adata s599 runs better scores around the 4k, 8k marks. And this was supposed to be an upgrade. What should I do???

When I get home ill post my benchmarks from atto.

SanDisk Extreme 240 on p8z77v pro

This is what i’m dealing with! r211 firmware