Sandisk e280 cannot play amazon mp3 files

After some trial and error, I discovered that the Sandisk cannot play any of my Amazon mp3 tracks, which is 255 bits. Any solution that does not require conversion?

I just downloaded an Amazon mp3 and it plays fine on my v2 unit. (“Strange Overtones” by David Byrne and Brian Eno–free today!)

It seems Amazon uses variable bitrates–mine is 239 kbps. But the Sansa can handle variable bitrates.

I’m only guessing but I think it’s probably a tag problem.

I wonder if you are trying to play a classical-music file that has a lot of information in its tag. There is a character limit, though I don’t know what it is, on the number of characters in a tag, and composer plus conductor plus orchestra plus soloists can add up. 

I suggest you get the free mp3tag (Google it) and do some tag editing with it. When you install, have it add itself to context menus (a checkbox while installing). After you install, set the default under Tools/Options/Tags/Mpeg to Write ID3v2.3 ISO-8859-1.  (Amazon already uses ID3v2.3, a good start.) You can also set it to make Comments <blank> (another place that can break the character limit). 

Take a look at all of what mp3tag displays, and see if you notice anything else odd about the tag, like foreign characters or very long entries in various fields.  It’s definitely not a problem with all Amazon files–and a good thing too, since unlike iTunes files there are no DRM problems.

Thanks. The album is The Knack-Get the Knack and under advanced tag editor in WM10, there are no foreign characters. Is there another way to transfer the music besides Windows Media Player? Under Advanced Tag editor<Comments<Text, could this be causing the problem: “Amazon.com Song ID: 205761656” Is this too long?

Yes, there is another way to transfer songs.

Go to Settings/USB Mode and change it to MSC. Voila–your E280 now looks like two disk drives (one for the unit, one for the microSD card slot) to your computer, and you can just drag-and-drop the file to it. Anywhere you want except Photos or Temp, and you can make your own folder(s) if you want. 

There’s a catch. Using Windows Media Player, you were transferring via MTP, the other USB setting. Your computer can only see files transferred in one mode at a time–either MSC or MTP. 

You probably had the E280 on Auto Detect, which goes to MTP if it sees Windows Media Player 10 or 11 and MSC if not. 

MTP mode lets Windows Media Player transfer digital-rights information on files that are corrupted–sorry, encoded–with it. It’s the only way to use tracks from subscription services like Rhapsody or Napster. MTP and WMP also let you sync, do WMP playlists (though there are other playlisters) and coordinate your library through WMP.

But Windows Media Player does, at times, just do goofy things with songs. I can’t imagine why something as simple as a Knack song would cause problems, but you should try deleting the song from the E260, switching mode and transferring it again via MSC, and see it behaves better. 

You could also try erasing that Comments, but that doesn’t seem very long. Just for the sake of science, try sending it over unaltered via MSC first. 

I’ve never liked WMP and I don’t care about playlists, so I have always used MSC, which is more straightforward. There are also other music-library programs around, like Winamp and Media Monkey, that will do playlists for the Sansa.  I think Winamp works in MSC mode (but you have to use another program to rip mp3s, because the free version of Winamp doesn’t).  

Thanks. Will songs show up under MSC mode if they were originally transferred via MTP mode? It looks like the Knack song was transferred, but it is not showing up under music. So it will not allow me to transfer the song again with the comment field blank since WM11 is stating the song already exists on my device. I would prefer to use MTP mode since all my music is in WM11.

@hikerman100 wrote:
Thanks. Will songs show up under MSC mode if they were originally transferred via MTP mode? It looks like the Knack song was transferred, but it is not showing up under music. So it will not allow me to transfer the song again with the comment field blank since WM11 is stating the song already exists on my device. I would prefer to use MTP mode since all my music is in WM11.

No. That’s what Black-Rectangle was saying. Files transferred in one mode are invisible to your PC when connected in the other mode.

Thanks. Now I understand. Could I upload and send a link to the mp3 file on rapidshare? Is this okay to do?

Even if the music is in WMP, the albums are sitting in a folder on your computer somewhere–probably My Music if you haven’t changed defaults. Search for the Knack and you’ll find the library folder.

Then, just to experiment, make sure you are keeping a copy of the album on your computer and use WMP to delete it from the Sansa (via MTP).

Then send the album (or song) over in MSC. This way we can figure out whether the problem is the file or WMP.

If you do want to switch to MSC, you can just drag-and-drop albums out of My Music (or wherever) while still using WMP to organize music on the computer–but that’s up to you. First, let’s figure out what’s making this file misbehave. 

And check your Messages.  

I changed the usb mode to msc, which as I now recall is the mode I have been using all along to transfer the music to the sansa with no problem until these MP3 amazon songs. I never had it in MTP mode. Unless, WM changes the mode automatically, even though the sansa says msc mode. I sucessfully copied the album in msc mode to the recordings folder and it played back some of the songs without any problem. So, it looks like it is WM. Obviously, I would like to have the knack in the same location as the other songs, and use WM if possible.

hikerman100 wrote:
I changed the usb mode to msc, which as I now recall is the mode I have been using all along to transfer the music to the sansa with no problem until these MP3 amazon songs. I never had it in MTP mode. Unless, WM changes the mode automatically, even though the sansa says msc mode. I sucessfully copied the album in msc mode to the recordings folder and it played back some of the songs without any problem. So, it looks like it is WM. Obviously, I would like to have the knack in the same location as the other songs, and use WM if possible.

Why would you put it here and not the Music folder?

Enquiring minds want to know. :stuck_out_tongue:

I did not see any music folder. Is there a music folder within the sansa, or do I need to set that up one? All my other music was transferred using WMP and the music is only visible using WMP.

The Music folder is a hidden folder in MSC. Don’t ask me why–it seems like a dumb idea to me.

You have to tell Windows to un-hide Hidden folders. In XP, the path is My Computer/Tools/Folder Options/Vew and check Show hidden files and folders. Probably different in Vista or Win7–check Help.

When you see Music in MSC mode, right-click for Properties and in Attributes un-check Hidden. The works on one version of the E280 (v2 but not v1). 

If you prefer keeping all your other hidden folder hidden, you can make your own folder in MSC mode. Call it anything except Music. 

Thanks. I think I own version 1. Do I create the folder in the sansa’s main directory (top level)?

When I transfer a song using WMP, I can still search for the song by song, artist or album. Can I still search for the song by artist, song or album if I copy it directly to the folder I created on the e280?

You can put the folder wherever you want. I have Albums on the E: drive (Sansa E200), and then within Albums are all the Artist folders and Album Title folders within them. But you could probably nest deeper if you want. Or you could make every album a separate folder (up to some limit, probably). Or you could un-hide Music and stuff them in there. 

The information about Title, Artist, etc. that you see on the E280 are tags within the files called ID3 tags. Since they are in the files, it doesn’t matter how the files were transferred. The Sansa will see them no matter whether the music was transferred via MSC or MTP. 

But your computer can only see MTP or MSC transfers, not both at once like the Sansa.  So WMP is only going to see what you’ve transferred in one mode at a time.

I know it’s confusing. The idea is flexibility–plain drag-and-drop and complete user control (and Mac and Linux compatibility) with MSC, Windows Media Player automation and digital-rights-management transfer with MTP.  Unfortunatelyl, WMP has quirks and things get tangled sometimes.

Thanks. I have transferred individual songs using WMP. This obviously goes to the hidden music folder on the sansa. The songs can be searched for using the artist, song or album menu on the sansa. I think the best bet is to delete the music from the sansa using WMP, unhide the music folder and drag and drop the music into the sansa using Window’s Explorer. I want to drag and drop individual tracks. Since each of the tracks have ID3 tags, I can still search for the music using artist, song and album. Is this correct?

I have version 1 of the sansa, so I have to see if I can unhide the music folder.

To un-Hide the music folder in v1, you have to un-hide all the folders on your computer. I do that on mine, but some people don’t like to do that. Unfortunately, you can’t just change the attribute on the Music folder to un-hidden–it gets hidden again when the Sansa v1 reboots.

But you can just make another folder–Albums, Songs, MeTunez, whatever–and ignore the Music folder. The Sansa looks for mp3s in every folder on the unit (except Temp, Photos) and lists them by the information in the ID3 tags. It’s not just looking in the Music folder. 

As long as you don’t care about digital-rights-management tracks (from subscription services) or playlists, MSC mode is fine. Did the Knack track work correctly transferred via MSC?

The ID3 tags are in the individual files, not the whole album. So if you transfer tracks 02, 05 and 10 they will still play in that order, even if the other tracks aren’t there. However, if the tags in the track number fields are 2, 5 and 10, they will play 10, 2, 5 because the Sansa reads the first digit.  That’s why I use mp3tag and run the Auto-Numbering/Leading Zeroes tool.

Thanks. I may go ahead and do that. Am I correct in saying that I cannot combine music transferred using WMP and music transferred to another user created folder? I think this was discussed in previous posts. The knack music transferred and played back okay using the direct copy method. So WMP is the issue. Sandisk told me yesterday that the player could be corruped and it may need to be re-formatted again.  This means that the player corruption is causing amazon mp3 files not to be transferred, even though WMA audio transfers okay. I think it is a ID3 tag issue on WMP side.  Re-formatting is a last resort, as I have nearly 8gb of music.

You can transfer some of your music by MSC and some via MTP and the Sansa will see it all. Your computer will only see one or the other.

With 8GB of music you may be running into a some limit on the total number of files, or of characters in the database that lists Artist, Song, etc. 

Reformatting is ridiculous. Don’t waste your time. 

Thanks. I had set up the post on the alb file issue. It looks like all my music from a certain date (including wma) did not transfer. I did transfer two or three wma music tracks without any problem a few days ago. These tracks already had an existing folder on the Sansa. I noticed the MP3 songs were missing, because I wanted to search by artist and could not locate it. Sandisk recommended re-formatting the player. I did do a disk error check and it could not find any errors. So, there could be a limit to the number of artists, etc. Actually, I think that could be the issue. All the MP3 music did not have an existing artist folder on the sansa.  

I know this is an old post, but better late than never for those who are struggling with this, maybe they will see this post. I have a sansa e280 and use WMP 11. After updating to WMP 11, I could no longer sync playlists. I tried ALL the recommended actions, including formatting, USB settings, rebuilt my library, etc, and nothing worked. Only 2 playlists would load, the rest just ignored everything I tried. FINALLY, I realized that WMP 11 fills in a field called ‘Composer’, which it never did before and does not show in Windows Explorer, even in the advanced properties for each song. When I tried to load a freshly made playlist, only 2 songs showed up on the player, and in WMP only those 2 songs had NOTHING in the ‘Composer’ field. So in the library tab, for EACH song, I right-clicked, selected ‘Advanced Tag Editor’ and removed everything in the ‘Composer’ field. If you are in the library tab, you can also right click the composer field, click ‘Edit’, and backspace to remove ALL text. Lo and behold, suddenly ALL the songs on the playlist sync to the player! I don’t know what dumbass decided there needed to be a composer field in WMP and why nobody’s figured this out yet, and WHY is there no option to REMOVE ALL for the composer field (cuz that would be smart I guess)  (and of course they’ll tell you it’s the sansa instead of trying to figure out what THEY did wrong), so BOOT TO THE HEAD to the dumbass. I hope this helps somebody out; it might make it worth the hours and frustration I experienced with this.