SanDisk Cruzer Glide 64GB Flash Drive - Wont Format

I just purchased a 64GB Cruzer GLide Flash Drive and when I tried to format the flashdrive. On the Format screen, the capacity is locked at 64 MB, and wont let me change it to the actual size. I tried to format it to this size anyways and I keep getting an error message telling me that it failed to format.

I have tried to format it on several computers, but it always has the same result.  Is there anything I can try? 

it will need to be replaced. contact sandisk support to check warranty status. 

Or, if you recently bought it, it might be quicker to return it to where you bought for a refund or exchange.

If it’s new it should already be factory formated, so why are you trying to format it?  Are you able to write to it?


I have exactly the same issue with my SanDisk Ultra Fit 128 GB USB 3.0 Flash Drive. Exactly as the OP describes, in the pictures and everything.

Brand new, directly out of the box I insert it in the USB port in my computer. A message appears, “The drive needs to be formated before use” (or similar, my OS is not in english). As an answer to question by user Ed_P, no, the drive is not accessible at all. Double-clicking it in Windows Explorer leads to the format message stated earlier. Formating it does not work. I have tried several alternatives, fast/slow format, different file systems. I tried fixing/formating through Computer Management/Disk Management. Same result. According to Disk Management, the size of the drive is 64 MB and the file system is RAW. See attached pic.

I originally bought two drives and had them returned today to the retailer (upon checking, he had the same issue with them on his computer). I received two new drives as a replacement. Same issue with both of them (!).

Does SanDisk care to comment? Is this a general issue with all SanDisk Flash Drives? Does the issue relate to a certain product (ie. Ultra Fit), or a certain size?

SanDisk USB Flash Disk problem (4-1-2018).PNG

definitely not an issue with all drives. none of mine do this. where are you buying them from? there may be a problem with what the seller has. Have you tried the drives on any other computer? Same result?

This is a user forum though. I would suggest you contact sandisk support directly so they can look into this for you. 

Thanks for the reply! Yes, I tried on my laptop, same results on all four drives. The seller is one of the bigger computer stores in Sweden. Maybe they have a bad batch…?