Sandisk Cruzer Fit 16gb not playing in Landrover Discovery 4

I just bought a new Cruzer Fit 16gb flash disk for use in my 2011 Landrover Discovery 4 but have been unable to play anything… 

After loading music onto the flash and plugging it in the car recognises that it is there and begins “connecting to USB”. It never gets any further than this.

The car accepts FAT and FAT32 formats, which this usb appears to be, and from Landrover forums I see that many people successfully play 16gb and larger flash drives in the Discovery.

I did briefly try a 4gb Transcend flash to see if the car was problematic, but this seemed to read fine quite quickly.

I have tried waiting, thinking it may just take a while to initialise, but I’ve left it for about 10min without success.

Any ideas on what may be creating an issue or suggestions I could try to get this working as I bought it specifically for this purpose.

Thanks all.

What is the format of the files? Most car systems will only recognize and play .mp3 & .wma.

Thanks for your response Tapeworm.

The car recognises .wma and .mp3. The music is all in either of these two formats.

To simplify it I deleted everything off the flashdrive and left just 2 albums of .mp3 format in 2 seperate folders… still no change. I sat for about 5 min in the car and all it said was “usb connecting”. When I used the 4gb Transcend it found the audio file within a few seconds.

I would conside that the 16gb is just too big for the car to handle but for the fact that I have read on various land rover forums of others having no problem with 16gb usb’s. I would try another 16gb usb to be certain but dont have one as this was purpose bought. I may ask around for a friend who has one I can try if no luck here

Ok, so i also tried a quick format of the drive (though it was already FAT32)… Still no help

Something might be wonky with the flash drive itself, although any issues should have been cleared up by formatting. Do you have another similarly sized drive to try? I’m using a 64GB drive (reformatted to FAT32) in my Kia Sorento with well over 4000 tracks on it and absolutely no issues.

This and the fact that others have reported sucess with the same size drive in their LandRovers makes me suspect the drive itself.

Yeah I’m hoping to try another 16gb flash today to check. In the meantime I’m trying varous formats. Do you think unit allocation size in the FAT32 format might affect it? Better to try smaller or larger?

Hi Tape worm, I’m new to this and just joined. I have a question but not sure on how or where to post it.

How do I start my own forum question?

But just incase, my question is… I have a new sandisk 64 GB Slide Cruzer. I loaded X amount of songs on it. MP3 files.

Then when I added more the first group I added is in alphabetical order, then the next group I added is also in alphabetical order but not with the first goup. It does this every time I added songs. Here is an ex.

Lets says on 10/31/2016 I added 5 songs,


Then later that day or days later I added 3 songs


I want the list to look like this…  aabcdemt   but instead it loads the songs like this    abcdeamt.

Why?  Can I and how do I fix this?