16GB Cruzer Fit won't work in MP3 player

I bought two new 16GB Cruzer Fit flash drives to use in my MP3 player. I chose the “Fit” because it’s much smaller than other flash drives. The 16GB Cruzer (long stick) worked just fine in the player, but the Fit will not.  BTW - both flash drives work just fine in the PC with WIN XP.  Thinking that it might be a formating problem, I used CHKDSK to read the allocation unit size out of the Cruzer that worked, then reformated the Fit with the same allocation unit size (FAT32, 64K byte allocation unit size). However, it still does not work in the MP3 player. I tried reformating the drive with every allocation unit size from 4K to 64K - still won’t work in the player.

I’ve disabled Autorun on my PC, so there is not autorun.exe or autorun.inf on the flash drive - just MP3 files in the same directory structure as the flash drive that works.

There is something fundamentally different between the Cruzer Fit, and a standard Cruzer.  What is it ?  Is there something in the MBR that the player doesn’t like ?

OK. I downloaded a software tool, and performed a “low level” format on the drive. Then, I created a primary partition on the drive and performed a high level format. MP3’s were copied to the drive, but the MP3 player still will not recognize the drive. Although the PC will.

Once again, there appears to be something fundamentally different about the Cruzer “Fit” version. What is it ?

Should I cross SanDisk off my list for flash drives ?

Surely a “Guru” has read this thread by now, so there must not be an answer - or maybe there is an answer not willing to be shared - no matter.

These seem to work fine on my PC, but for me, that’s not enough. I’ll sell off my Cruzer Fit’s, and try another brand.

Good Luck to all.

No need to reply.

Generally, no responses mean that no one has an answer to your question. I doubt anybody’s keeping any secrests from you. :wink:

Your post has only been here one day though; not everyone stops by every day, so you may still hear from someone with a suggestion or solution.

shhhhhh  let him go complain on someone else’s forum.   Obviously his MP3 player doesn’t have one.   :smileyvery-happy:

Year later but I am stuck with this problem currently.

Two 16 GB blades that I’ve had for years work very well in my MP3 portable sound system (NJA NJA240)

BUT some new 16 GB ones I bought recently are not recognized at all by the player. 

ALL work fine in my PC iunder WIN7 and all are FAT32 formatted as a single primary partition

The ones that work have the following numbers on them:

D33724      SDCZ50-016G    BL1202ZJZB   TAD-SDC250(B)

The ones that DON’T work have the following numbers on them:

BL190426842B  R-REM-WDT-SDCZ61

Help, someone must know what the change is between the older ones and the newer ones.

Return the ones that don’t work to the seller and get replacements.