Sandisk Cruzer Edge 32g

Hi recently purchased the above usb.  I set it up on a work desktop and put some files on it.  I tried it on my home laptop (HP pavilion g series Windows 7) and it is not being recognised.  The strange thing is, it is showing up up on the “safely remove hardware and eject media” icon as “Eject Cruzer Edge”.  It is also showing up under Device Manager as a Disk Drive.  However, I cannot access any files on the usb.  I am only an ordinary computer user - I don’t have any great knowledge - so please, if you can help me assume I only have very basic knowledge of computer and software. 

Looking forward to getting some help.

Carolyne

Does it show in Windows Explorer?  Does it have a drive letter assigned to it in Device Manger?

Hi Ed

Apologies for the delay.  We may be on opposite sides of the world!

No it does not show in Windows Explorer so there is no drive letter to report.

I tried it on a Mac today also and it registers once it is plugged in.

There must be something blocking it on the HP laptop.  Unfortunately I cannot run the particular files I have on the usb on Mac as they are Microsoft Money files. Its not a super urgent matter as I can put the files on another usb when I get to work tomorrow.  However, I would still like to get to the bottom of why it doesn’t register on the laptop.  Other usbs register immediately when plugged in so I don’t think it is a problem with any of the ports on the laptop.

Anything strike you ie some setting that maybe needs tweeking.

Thanks

Carolyne

I would suspect some security app or setting on the HP is preventing the drive from being recognized due to the files on it.  Will be interesting to see if they work being on a different USB drive.

Another possibility is a conflict with the other USB devices you use in the HP’s USB port.  Windows could be attempting to assign the same drive letter to the SanDisk as it has assigned to some other drive and it’s driver is incompatible.  Can you try to manually assign a drive letter to it? 

I have no idea how to do that. Perhaps you would be good enough to tell me how

Sure. :smiley:  Click on Start > RIGHT click on Computer > click on Manage > click on Disk Management > RIGHT click on the SanDisk drive > click on Change Drive Letter.

Hi Ed

Tried that.  The problem is the Sandisk is not showing up there.

I have © drive, HP tools (G), Recovery (D) and System

No Sandisk.  That is the problem it isnt showing up anywhere, but in the icon on the bottom right corner to eject it.

When I click on this and open devices and printers it shows two devices:  Cruzer Edge and xxxxx’s computer.  When I right click on the Sandisk here the only options I have are Eject, Create Shortcut, Troubleshoot or Properties

Sorry can’t complete your instruction.

Carolyne

I’m sorry c1aro I’m out of ideas other than to return it to the seller.  Sorry.

Bummer!

Well, thank you for taking the time to try and sort it for me.

I’m still convinced that there is just some small “tweak” that needs to be done on the laptop as the usb works on other pc and mac.

Thanks Again.

C

I agree if it’s working on other machines.  I suspect a security setting of some kind, could be in the Windows User Account Control Settings, or an antivirus app.

Please post back if you figure it out.

C,

I forgot, there are reports of apps that conflict with the Sandisk drives.  Check out the postings in this thread:  http://forums.sandisk.com/t5/All-SanDisk-USB-Flash-Drives/Windows-7-Explorer-not-showing-drive-while-it-shows-in-computer/m-p/290694