SanDisk Cruzer Blade 8Gb works on XP but doesn't on 7


I bought a Cruzer Blade, put it in my laptop (Win 7), it reads it, but I can’t copy any file on it and when I check Properties, it says 0 byte free of 0 byte total capacity.

I tried with a desktop PC on XP and everything seems to work perfectly. It also seems to have a ‘‘Briefcase’’ program already on the drive.

U3 isn’t on the drive and when I tried to install the update for Win 7, it asks me to insert a compatible drive. If I try the uninstaller, it also asks to insert a drive with U3.

Some help would be appreciated!



@thibz wrote:


It also seems to have a ‘‘Briefcase’’ program already on the drive.


The drive should be empty. try formatting the drive on the xp pc use FAT32 file system with default allocation size. 

Just did. Thanks for your help!

Still doesn’t work. It says 0 byte free / 0 byte total and I can’t copy any file on with Win 7.

(Sorry for the late reply, I was in mid-term exam week so I was running for time!)

I have this exact same problem. Works on PC with XP, but doesn’t work (or even get recognised) on Dell Inspiron N5110 laptop with Windows 7. Can’t seem to find any useful information everywhere - just info telling me the Cruzer Blade 8GB is compatible with 7 and does not need any additional driver download. I don’t think this is true, though. Advice??? Lots of people online seem to be having the exact same problem with this particular SanDisk product.

Is this issue answerd? This is  difficult issue.Is there a specefic storgae for 8GB?