SanDisk Clip Sport Firmware 1.38 released

Reply to users NALF and jamesqf:

I tried using The Google to search for advice how to recover from the nasty problem of “Stuck on Flower Boot Screen”.

I found this suggestion from user Saratoga on the Rockbox user forum in March 2014.

Sounds like the file system is corrupt.  The bootloader has a failsafe USB mode that shouldn’t care about that.  Turn off the player, hold down the select button, then plug in USB.  It should then mount in Windows (the player itself will have a black screen).  Check the disk for errors, fix any that appear.  Probably then everything will work.

Please report back here with your results and comments ???

I only tried to upgrade the software because my songs were listed as ‘tracks’ and my GoLists 1-3 will not show.  I am using windows 10, latest updates etc. I have NO sim in card slot, the 8GB version I bought is big enough for my needs.  the upgrade.hex is the correct 28,491 kb in size, my power was FULL when I unplugged after tranferring upgrade.hex to the L drive which is the ScanDisk Clip Sport.

The issue I was having as I stated, I made SURE all tracks were NAMED not just track#.  I had hand deleted all in GoList 1, and had a few songs in GoList 2, & GoList3, which I left ALONE.  Now I am on USB stick which does NOT register with Windows as the previous L drive when I plugged it in to add and delete different songs.

Personally I PREFER to shuffle songs, but if you put SHUFFLE to OFF on main menu then if you place album of songs it SHOULD have started right through them all, move to next album and repeat procedure.

Another way to do songs in a row is to make one large audio file as I did with Jefferson Starhip song. See:

It plays all four songs on my site and also on the scan disk.  So IF you buy a new player, like I might do if letting this thing stay plugged in for overnght does not “fix” the issue, I will buy a NEW player, jusr not from THIS manufacturer tomorrow when I expect nice weather, going shopping to get my Mountain Dew on last day of sale at two stores @ 12 pack cans 4 @1.99 per 12 cans.

For putting all songs together try audacity its free and works great.

I’ve already sent this little thingy back because it came in GERMAN and would NOT allow me to switch to English.

Otherwise I like this little Clip Sport.  I have plugged into USB port and it’s on with ScanDisk showing in Red color.  I don’t care if it deletes all songs since I have already downloaded all songs to harddrive.

Sad that this company is not getting it’s software working properly.


Since I had the reset button pushed down using giant ‘clothspin’ and didn’t start I went WalMart got Eclipse Fitclip 4GB and cord for car  plug in to play on the road for less than $20 US$, on-line manual downloaded, worked well last night, now re-charging it, added my OWN folders, as many as I want not just 3 GoLists…

Was going to go to Best Buy and get something similar to SanDisk, then thought better of that since my first one came in German and wouldn’t change out, because you had to be able to READ German to do it, BestBuy sent it back for me, but now this upgrade frack-up has me over the edge and not bying ANY product from company again.

Sorry SanDisk…should be SURE product it working before selling, especially sending GERMAN default to USA customer outlets, and that your firmware updates…WORK.


Tried plugging in USB with the select button held down, but no luck.  On Linux, as I don’t have access to a Windows machine.  /var/log/messages didn’t even show that the hardware was detected.  I’ll try some more after the weekend.

How do I update new firmware from my phone to sandisk clipsport? Can I do it from the SD card? Need help. No computer, just Android phone

You need a USB connection to a PC (or Mac).

You need to copy the upgrade.hex file into the root directory of the player (not the micro SD card).

I have not learned about using an Android device for managing files on a Clip Sport.

Anyone else know about this possibility?

I’m still having a curious problem - when playing a mp3 file with garbage or corrupt tags the files play fine, but the ui locks up completely until playback is done. This has persisted since few previous versions and doesn’t seem fixed yet.

@yoshi314 wrote:

I’m still having a curious problem - when playing a mp3 file with garbage or corrupt tags the files play fine, but the ui locks up completely until playback is done. This has persisted since few previous versions and doesn’t seem fixed yet.

Fix your tags. Simple fix. No firmware update will compensate for incorrect ID3 tags.

I have a Clip Sport, it lasted all of a few hours. First the pause quit, then it would play, for a while and it finally froze up saying Sandisk constantly. When you do a reset, yes I have tried it endlessly, it turns off, but comes back to sandisk when released. The computer will not recognize it, even with the button held off, releasing it does nothing but give you sandisk. Running it dead will probably do nothing also, it’s about to get a BFH. I will NEVER buy anything from this lousy company again. It has a total of 2 hours on it, the good thing is I didn’t lose any music because of this POS! That afore mentioned hammer is looking pretty good and I DON’T want another one!

Why not return or exchange for another one where you purchased it from? Truth is, defects from factory happen; not only from Sandisk or even mp3 players, but everything you buy today . . . even $50k cars.

The issue is that other mp3 players i had didn’t lock up playing those files. And this one does. I treat it as a bug.

I also had similar issues with files that have valid tags, tbh.

Try setting the region to North America or U.S. .

I’m having a problem with audiobooks and firmware 1.38. If I load more than five or six audiobooks only the first five to six books are visible. The rest of the books can be seen in folderview and shows up as albums in musicview. The audiobooks are tagged with genre “Audiobook” and placed in the folder “Audiobooks”. Does anyone else have this problem?

Here are a few quick suggestions for you to explore.

  1. Make sure you do not have more than 2000 audio files saved into your player storage space (or the micro SD card).

  2. Make sure the first 12-16 characters of the Book names have sufficient unique specificity between all the audio books in your player.   You may need to edit the ID3 tags.

  3. If you save the audio books files in the main Audiobooks folder, they should not be displayed as music files.

      When you use Books mode, the player will create one restore point for each audio file.

      When you use Books mode, you can select 1 of 3 playback speeds: Slow, Normal, Fast. 

  1. The Clip Sport and Jam do not recognize the Genre field in the ID3 tag.

Since updating firmware to 1.38 all audiobook tracks show as 34 or 35 seconds in length, so I have no idea how much time is remaining as I’m listening to a track.  Is there a way to downgrade back to 1.36?

Just got a Clip Sport. Out of the box it was on I’m on firmware 1.38, but  just to be sure I did the upfrgae. No problems.

But I have this annoying problem: in Music view all band names and album titles are truncated to 12 characters (but not song titles). I guess this has to be related to improper reading of tags, as in the Folders view everything is fine.

Note: all of these music files were fine on my Sansa Fuze, so the tags are not the problem.

I would never have replaced the Fuze if the headphone jack hadn’t become faulty. It’s so much nicer than the Clip …