SanDisk Clip Jam not working

Hello all,

I purchased a clipjam in February this year from Amazon. It was all working fine (sound was quieter than I’d like it to be, especially in the gym!) but then all of a sudden it just decided to stop working. 

I’d press the power/enter button and the SanDisk logo would come on, but then nothing after that. I’ve tried holding the power/enter button down for a long time but to no avail. I’ve tried charging it, which at first says it is charging, but now it’s not even doing that.

It’s only May so I’ve not had it for very long at all. Could anyone let me know as to why this has happened and how it can be rectified? 

I don’t have a large selection of songs and didn’t want to waste space on my phone, hence the purchase for a cheaper alternative so it’s frustrating that it isn’t working! Please help!

Many thanks,


it sounds like you have tried resetting the player and it is still frozen on the loading screen. If reset dont work it would likely need to be replaced. Contact sandisk support to check the warranty status of the player. 

Thank you