SanDisk Clip Jam Firmware 1.05 Download and Installation Instructions

Firmware is the software code that powers your Clip Jam. You can think of it as the operating system.  SanDisk actively and periodically updates the capabilities, functionality, and reliability of the Firmware.  For an optimal experience with your Clip Jam, SanDisk recommends that you update your Firmware with each new release.  It’s fast, easy, and free!

SanDisk has released firmware version 1.05 for the SanDisk Clip Jam. Download links and the release notes are available below.

SanDisk Clip Jam Firmware 1.05 Download and Installation instructions

Manual Firmware Update (Download and Instructions)
Manual Firmware Update (All Regions) - Click here to download

All languages are now in one firmware version. After firmware update you will need to select your Language and Region preference.

• Remove any external card from the Clip Jam before performing firmware update
• Ensure your battery is > 50% full.
• Plug in your SanDisk Clip Jam to your computer.
• Download and save the upgrade.hex file linked above to a folder on your computer.
• Drag the file to the root directory of your SanDisk Clip Jam
• Disconnect the SanDisk Clip Jam and let the firmware update begin.
• Once it finishes doing its update, it will turn itself off.
• Turn the Clip Jam on, Select your language and region preference
• Once it is back to the main menu, head to “Settings” >“System Settings”> “Info”, and verify the “Version” is now 1.05".

SanDisk Clip Jam Release notes

This new firmware has various enhancements and bug fixes, including key fixes listed below. Upon completion of the firmware upgrade, the device will turn off; power on the device to complete the upgrade process.  If the device does not initiate or complete, press & hold the Power switch for 15 seconds to reset the device and then press and hold power button again for 1 second to restart

New changes since 1.03


  1. Add track number sorting for ogg files.

Bugs Fixed:

  1. Fixed track number sorting issue for Audiobooks
  2. Add AFI.bin for ogg file FF/FB “File format not supported” issue.
    3. Add AFI.bin for ogg can’t playback (random issue).


After the installation of 1.05, the player does not turn on. When connceted to computer, I can still pass files to the internal memory, but screen does not turn on.

please advise.

have you tried resetting the jam? hold the power button for 15 seconds and then turn it back on normally. If it is still the same it may need to be replaced. If that is the case contact sandisk support for warranty replacement. 

Track number sorting issue was only partially fixed in the new firmware.  I loaded a book where the Track tags went from 001 to 166.  On my Clip+, track 001 corresponds to Title 101… as it should, but on the Jam it corresponds to Title 701… and that is where the book begins playing.  I hope that 1.07 finally gets it right.  :wink:

I dimly remember reading that the Clip Sport and Clip Jam do not properly use 3 digit prefixes.

Try to devise a numbering scheme that goes from  01-99 for audio track numbers within one album title.

The only way to do that is to merge tracks.  If what you say is true, it is a ridiculous restriction.  Luckily I still have 2 Clip+ players which don’t have such a problem.


is there an available firmware that allows to disable the fm radio from Clip Jam?

Thanks a lot!!!


@nathasion wrote:



is there an available firmware that allows to disable the fm radio from Clip Jam?


Thanks a lot!!!



No there is not. In Settings > System Settings > Customize you can turn off the menu options including radio but that is the only way to remove the radio from the main menu. It can be reenabled at any time. 

this is just perfect!!


  1. Fixed track number sorting issue for Audiobooks

that is for mp3 or audible or both??

Hi, I am trying to update a Clip Jam running Firmware version 1.03. The most recent version is 1.12. When I try dragging that into my root directory and unplugging the player from my laptop, nothing happens.  When I try clicking it on directly from the root directory, it says that the file format is not supported.   I tried updating to 1.05 rather than 1.12, but I had the same problem.  Help!

PRoblem solved. Used computer with Windows 7 and it was fine.