Sandisk 8 GB cruzer won't work on my other pc

Ok to put this simply my usb flash drive will work on every pc I have tried but one… when I put it on the other pc its very slugish to show up and when it does it has a letter (in this case F:) i can’t do CHKDSK because of “cannot open volume for direct access” I have uninstalled and reinstalled the driver in the device manager… tried to change the letter which won’t work i forget the error given. its NTFS it says it has 0 space in general… theirs supposed to be by the pc nothing and no space to even work with on it… but the laptop im writing this from shows the files on it ext ext (linux laptop) the pc that is acting up is a windows 7 pc… Any help would be really nice at this point I had a external hard drive do this same thing someone said maybe a master boot record issue? but I could never fix it… which was bad for me considering it had over 1.5 TB of data on it… it did this exact same thing but on another desktop (windows 7) it was a western digital “My Book” 2TB so I’m hoping anything that fixes this might have a chance on my external…

Obviously there is something on the problem pc conflicting with the Cruzer.  Any other USB devices plugged in?  Try shutting down, removing them and rebooting.  Then try the Cruzer.

Other possibilities include security settings and security apps (AV, FW, etc.)

Av is eset smart security.

not much is plugged in…

skull candy’s (analog plugin)

Razer naga.

Razer orbweaver i believe or something close to it.


If any of these are known would really help I’m headed to bed atm will try this info later.

Ty for the reply.

(P.S. my other windows 7 pc uses eset as well. (which is the one that had issues with my external so maybe thats a common linking but I’m not sure as of yet. it worked fine for a while before it did this same thing (the usb did too)

Usb drive works on my other windows 7 pc just fine no hickups (one that had the issue with the external)

this is kinda odd… Eset was on and protecting without an issue.

Razer naga.

G510s gameing keyboard.

nothing else was plugged in at the time. that pc also uses a

G35 headset.

Strange.  Anything in the machine’s Eset logs around the time the Cruzer was plugged in?

On occasion my netbook doesn’t accept my Cruzer but rebooting it resolves it.  Memory getting corrupted somewhere/somehow but only an inconvenience rather than a problem fortunately.