sandisk 128gb UltraPlus turn into an incorruptible storage card

I have a 128gb sandisk ultra plus, I only use less than 50% of the space with my Note10+ cellphone. I was taking video and suddenly when I press the stop button it say’s “can not write in the card”. So I removed the card from my phone and make a backup copy, then put it back into my phone and tried to format it, but it failed. So I use my desktop to try to format it, but it failed. I tried diskpart, the formatting tool that is supplied by sandisk and also failed. Weird is, I tried deleting the files and it shows it was deleted, however when I ejected it and put it back into my cellphone the files are still there. So I remove it again and put it in my desktop and voila, the files that I deleted using my desktop are back. So I tried deleting it again, then eject, but this time I put it back to my desktop and voila the files are still there. I removed the card without properly ejecting many times and it did not corrupt the card at all. So now I have an incorruptible card, but I can not add any data anymore ;(. Anyone here had an experienced like this?