repair corrupted pendrive

Good Afternoon:

  I have a problem with a 4Gb pendrive that I know can be repaired, just haven’t found the correct procedure. This flash (pen) drive was accidentally remove before 'shutdown" and now, cannot get it to “mount”.  The data on it is insignificant, but, if possible, I’d like to keep it. Cannot format nor open this drive. Have run cat /proc/scis/scis and fsck. Will post results IF requested. I had another flash drive with the same symptoms and ended up junking it. Don’t want to/ need to do that again!!! I’d appreciate someone: anyone who could help out!

Thank You:


Have you tried going to Disk Management yet and change the drive letter assigned to it? That could be a work around.

Hey stasher:

   I tried to change the designation from G:\ to J:\ and it did nothing. I tried to mount it and got “Does not contain a recognized file system”. This is what has stopped me from being able to repair it. And, BTW, I have a Sandisk 16Gb that only shows 14.8 Gb, even when it’s “supposedly” blank? Any ideas on that (i.e. missing about a full Gb). Thank s for responding

Stay Sharp:


ADDENDUM TO: repair corrupted pendrive

   I tried to “force mount” and got error report “lost boot designation”. Would “Boot-Repair” help me correct this? Could you recommend a procedure that would repair this pendrive for operation?


Rixter, your lost GB can be explained in this thread

Until the industry promotes products read as gibibytes or GiB (binary) then this will always be confused.

To have a FULL 16GiB available the drive would have to have a REAL storage capacity of 17.18GB (rounded) or 17179869184 Bytes.

The 16 GB Sandisk Cruzer starts out with only 15698231296 bytes or 15.7GB which is actually only 14.62GiB.



   Thanks for the link/explanation. I understood there was to be a certain amount of difference between advertised and actual useage. However, I didn’t feel I should’ve lost 1.2Gb!!! I have an 8 Gb that actually allows for 7.6.Gb useage, so you see why I felt there’s a discrepency (7.6x2=15.2)  Something that was not explained in the link was the manufactures also allow for a certian percentage of blocks for “reallocation”, thus reducing actual useage space. Anyway, yes it’s a"marketing" ploy and should be advertised in 'actual" and not 'assumed" Gb useage. BTW…any ideas about how to repair 'lost root designation"?

Stay Sharp:

Rixter, If it were me, I would use Recuva from Piriform. It is a free product that only wants to install Google Chrome as a browser that you can decline through the installation options. This product will try and allow you to salvage the data from your drive (TO ANOTHER DRIVE!). After salvaging the data you can then reconfigure (format) the drive. Recuva will allow you to select the drive even without a drive letter.

to _ KyZIX _

_   _    I’ve tried Boot-Repair, Gparted, disk utility, and MSWin to try to "format the drive. I’ve tried to write all zero’s to it. I’ve tried DBAN DoD erasure…none of which worked. The problem is “lost boot designation”. I need to repai/rebulid that before I can do anything with the drive. I can “read” the disk, cannot write to it, I know what’s on the disk, but it’s not all that important.(LM17.1 rebecca). I just want/need to get the disk back into service. Funny, I’ve googled/binged that (lost boot designation) and am getting very little/next to nothing about it???. Are there Sandisk “techs” I can dispose at this sight? Perhaps this is a detail they may be able to help with. And please, I mean no offence to you or anyone who has tried to help. It’s just that noone seems to know what I’m talking about.

Stay Sharp:


I can “read” the disk, cannot write to it,

Read only mode is a known problem and the only solution is to return the drive for a free replacement.  There is no fix for it.

I’m going to ask:

   IS THERE A WAY TO FORCE MOUNT  THIS PENDRIVE? I use a linux O.S. and when running dmseg, I get “buffer I/O error” . But what’s so puzzling is, when plugged in MSWin,  I check the drive and get “healthy partiton” “drive OK” even though it won’t mount??? I know…with the price of flashdrives these days why even mess with??? Because I like to fix things…if possible! And, does this site offer any advice/help from their 'techs"? If so, how do I contact them?



Well, the drive is history. I tried 4 different pendrive" restoration programs and none could do a thing for it. It’s now on it’s way to the landfill. I want to THANK everyone who offered help/assisstence. I appreciated it!!


@rixter wrote:

I’m going to ask:


   does this site offer any advice/help from their 'techs"? If so, how do I contact them?


This is a user’s forum, not a SanDisk tech support forum. There are no “techs” here.

You can contact SanDisk’s Tech Support here:

_ Tapeworm: _

   Thanks for the link.  I’ll put this away for future reference. The pendrive is history. Tried 4 completely different programs to “repair” it and every one failed .Somehow, it destroyed the MBR and subsequently, couldn’t boot nor repair the MBR and wouldn’t mount. Seems a **bleep** shame, but that’s the second pendrive this machine/O.S. has destroyed in the past 2 months.

Stay Sharp:


Hi Rixter,

There is a manual procedure is available, maybe it helps you to resolve this problem. For the resolving this issue you need to follow below mention instruction

Open MS DOS Shell and Run this following command

Note: First you need to check your pen drive letter name that your computer system shows you after plugging. Here my computer showing me my pen drives letter name e:

Run this cmd >> chkdsk e:/r

It will check the corruption level of disk formation and repair the issues that is finding out

During the repairing process it show you warning message such as “the drive is not a Windows XP drive” that is no issue you can continue repairing procedure by pressing “Y”.

Once it’s done the repairing task, then it will ask you, do you want to save lost chains into files select yes.

Now all repairing process is done now you can see all data in your pen drive

This is very common procedure for resolving this corrupted pen drive problem. In case, through this command you unable to get back your data that means your pen drive is badly corrupted in this situation, I would suggest you try out a professional data recovery application that helps to recover SanDisk pen drive data without any complications. Read this article for getting brief information about this application:

TO:  walkerjonnie

  Thank You for your response. I WILL keep this on file. Regrettfully, I’ve already discarded the pendrives for I had not found anything that would repair them, and your reply came a bit too late. I hope that anyone else who may be experiencing the problems I had, will see this post and be able to save their pendrives.

Stay Sharp:


Nice link walkerjohnnie but you forgot to note that the app costs $39 for the Personal version and $99 for the Business version.

It kinda makes your posting seem as SPAM.

hello Walkerjohnnie, 

thanks for suggestion, I recovered entire data by using this tool.


If your pendrive is damaged and you are not able to access the file. Dont worry I have faced this situation and successufully recovered complete data by using pen drive data recovery software. Analyse the feature of the software by downloading the demo version for free.

Know  More: - Recover Complete Data From Corrupted or Damaged Pen Drive






 I have a 64 GB Sandisk pen drive which i use to store all my portable data. One day I plugin it in my friend’s laptop and try to open some files. But I found  that all saved folder become shortcut then on verious search I used a pen drive recovery software which recoverd all my data quickly.

link: -