Problems with 16GB card on Clip+

The following is what I just posted to Sandisk support as a support request. Anyone here have any advice? I’ve tried reformatting the card with the SD Association tool with no luck. :frowning:


I bought an 8GB Sansa Clip+, and also a 16GB Samsung MicroSD card slot. If I plug the card in and then connect the Clip+ to the computer, the computer tells me the USD drive is unformatted. I took the card out of the Clip+ and plugged it into a card reader, where it works fine. So, I copied some music onto the card and put the card into the Clip+. The Clip+ could then see the music. However, when I plugged the Clip+ back into the computer the USD drive still shows as unformatted. So, I cannot copy music onto the Clip+ the easy way. Also, if I connect to the computer and then unplug, typically the SD card is no longer readable in the Clip+. If I eject the card and re-insert it then the card is readable again. I am on the latest firmware version, 01.02.16P

Make sure to only insert or remove a card in the player while the player is off.

You could try formatting the card in card reader plugged into your pc using the SD formatter.

https://www.sdcard.org/consumers/formatter_3/

  1. I’d already tried reformatting the card

  2. Whether or not the player was on or not when the card was inserted doesn’t change the problem

very body wants to succeed. But when it comes to the question that which factor leads to success, opportunity or hard-work, different people will offer different answers. url=[http://sfasianescorts.com]San Francisco Escort[/url]

Some people think that opportunity is the first factor leading to success. They hold the idea, as a proverb saying, “Man proposes, god disposes”. url=[http://sfasianescorts.com]San Francisco Escorts[/url] Because almost all successful people have good luck and have caught their valuable opportunities, they believe that opportunity is a leading condition of the success. url=[http://sfasianescorts.com]San Francisco Asian Escort[/url] If seizes and makes the best use of opportunity available, one can succeed surely. In summary, to them, chances and lucks play the most important role on the road to success.
url=[http://sfasianescorts.com]San Francisco Asian Escorts [/url]

I’ve got the same problem here. The only differences is that my SDHC is a Kingston, works perfectly well until i put it in the player.

My list of things done to add to the above (my bet is we’ve got the exact same problem though…):

*On latest firmware, but tried using the one my player came with as well.

*I’ve formatted the SDHC-card several times. (With formatter ofc)

*Worked perfectly well with an 8GB SDHC for months.

*Formatted the player as well.
*Tried both ways of connecting the player (MSC/MTP?).

Others have had issues with the Samsung 16GB microSD cards. What “class” is the SD card?

I know poster’s have said they’ve formatted the microSD card, but have you used the SD Formatter 3.1 program to format the card? My Sandisk 16GB card had issues with my Clip+ until I formatted with with the SD Formatter program.

Also keep in mind that once formated you might have to create a folder structure (below) on the microSD card for the Clip+ to properly read the files.

/

|

± MUSIC

   |

   ± AUDIOBOOKS

   |

   ± PODCASTS

Sandisk Support’s response:

Thank you very much for the provided information. I would like to inform you that we are currently looking into the particular issue; we are hoping this will be fixed with the next released firmware update for your player.

Sounds a little like a standard “fob off” response to me, but maybe I’m just too cynical.

In response to other suggestions, I have formatted with the SD association as my initial post said.

Folder layout on the device seems to be not pertinent, as the player will happily read songs from anywhere on the MSC partition when playing songs, but doesn’t whenever you connect it to a PC.

The Samsung card is a class 10 device.


I have the same configuration (8G player + kingston 16G SDHC)

After a few tries, i removed partition from SD card and created a new partition and filesystem ( FAT32)

using gparted (under linux).

It helped… 

Thanks - putting the SD card into a card reader and repartitioning with fdisk and mkfs seems to have helped for me too!

I can now see the SD card when I plug the Clip+ into a Windows machine, when the Clip+ is in MSC mode.

Haven’t tried MTP mode yet, but maybe I won’t push my luck and just stay with MSC.

Cheers!

it appears that repartitioning helped with rockbox, but not with native firmware.

Hell, who needs a partition table anyway? :wink:

I created filesystem on raw device.

And it works like a charm.

So, hint for linux users : simply do  mkfs.vfat -F 32 -f 2 -n SDNAME -I /dev/sdx  

(where /dev/sdx is your SD card and SDNAME is your favourite label for the card)