Problem with the firmware of my E270V1

Hi everyone!

I searched for a solution to my problem, but could not find one anywhere, so I post this here!

Today, I got a Sansa E270 (6GB).

It seem to be a V1 modell. The installed firmware is 01.03.06P

I would like to install rockbox on the player, but there is no way to set the player to msc mode. (No setting for that in the settings menu of the player)

So I tried to mannually install a new firmware version in the recovery mode, but when the player restarts itself after the update, it still says “Version 01.03.06P”

Another strange thing is that the newest firmware version for the player seems to be 01.02.24. This seems to be a lower version number than than the version which came with my player, although the Date of my version is August 2007, while the newest Version from the website is April 2008.

So here is my question: Why don´t I have a USB-Mode setting in my player. How can I install a Firmware which enables MSC support?

Best Regards


That is a bizarre firmware number since the E200 units never got past 1.02.xx .

You should be able to force MSC mode by turning the unit off. engaging the Hold switch (so orange shows), holding the Record button and connecting. 

Could it be the old Hebrew beta firmware?

This thread sheds some light on the problem and also links to a solution.


To be sure, I rechecked it once again.

I can confirm that the Firmware version of my Player is 01.03.06P.

Release Date: 2007/08.

If I turn on Hold mode and plug in my player while the REC-Key is pressed, I get into the recovery mode. This is where I already tried to put in a new firmware file to upgrade (that 16MB Drive).

But I can´t access my players memory in MSC mode there.


Sounds like you have the Hebrew Beta firmware installed on your device.

Cycle the power on your Sansa v1, and see if you see the animated Lil’ Monsta on startup.  This little guy:

The Sansa cannot accept the correct firmware, since it doesn’t recognize the names of the new firmware files as valid.  What is needed is a simple renaming of the files as described here.

The pp5022.mi4 files needs to be renamed firmware.mi4 and the second file needs to be renamed pribootLoader.rom

Remember, these names are case-sensitive, and this only needs to be done for this original repair.  Afterwards, your e270 will recognize the standard mi4 and rom file names, if you wish to reload or change the firmware version in the future.

Bob  :smileyvery-happy:


Thanks for that hebrew-Thing!

After I reinstalled the renamed firmware files, I have finally fallen down to 1.2.24.

Thank you for that information. I would have never found it for mself!


Glad to see you have a happy Sansa!  Time to load that baby with some music.  I like the Lil’ Monsta animation, but that beta FW is notoriously problematic.  From now on, you can simply use the “stock” firmware names, no renaming required.

For the v1 devices, it looks like a split between fans of the .18 and the .24 firmware builds.  Both are quite stable. Hey,if you are interested in using the microSDHC cards (over 2GB), you have the future option of Rockbox to look forward to. 

For myself, I like the 2GB cards, as I can swap readily if I wish to switch music for Audible books.

Bob  :smileyvery-happy: