Problem with m230: Not enough space for Music DB. Please Free 8MB.

Ok so. Hi, I’m new in this forum.

So…  I wanted to listen to music. First the SandDisk Initializing came, then the Sansa m230 512MB came and then the error:

Not enough space for Music DB. Please Free 8MB.

And then it shows: No Files 0/0 . And the battery is full. I thought what the…

So I decided to connect m230 to my computer. First the initializing, then the error came, had to wait a bit, and then… the Sansa’s screen shows:

USB Connected MTP (and this popped up in my computer:  http://i30.tinypic.com/2i9jo82.png)

So… I opened Sansa m230 in my computer and the only folder I saw was: RECORD

Well… I’m sure that many of you would suggest me to format or reset. But… there’s a problem:

Where’s the format button? (http://i31.tinypic.com/dvoky9.png)

So… I tried to format under Computer Management . Device Manager > Portable devices > 
Sansa m230 . But… where’s the format? (http://i31.tinypic.com/10x7q06.png)

I browsed some topics and someone suggested to format under Removable Storage, but there’s no m230 .

Then I thought I try FirmWare update. But… the error popped:

 The following failure occured:Your device is in MTP mode. It can only be updated in MSC mode. Please unplug your device and switch to MSC mode if you want to check for updates.

But hey… how do I change it to MSC mode, coz… if I press the menu button on my m230, the same error always pops up:

Not enough space for Music DB. Please Free 8MB. I can’t do nothing in the menus. Aaand by the way, I have this mp3 player more than a year, so there’s no warranty or something for me I guess.

So… is there a way to do hard reset or something? Is there a way to repair my m230? Feel free to ask questions from me. I’d be very glad if you reply.

Aaand… sorry about my English. I’m not from English-speaking countries :smiley:

All the best,

MagicIsland

Message Edited by MagicIsland on 09-08-2009 09:04 AM

Hello MagicIsland you might need to format your device but it will delete everything on your player try to see if you can still save the files when you connect your device by following these steps;

http://kb.sandisk.com/app/answers/detail/a_id/1/kw/not%20enough%20space%20for%20music%20db%20error%20for%20m200/r_id/101834

hope this work :wink:

Yeah… it worked! The thing is was missing all the time was that I didn’t put hold/lock switch to lock.

Hehh… I already thought that I have to buy new mp3 player, but seems I don’t have to :slight_smile: Thank you so much, keberloo!

Im glad it work and Im happy I help :wink: anytime as long as I can help :smileyvery-happy: