Podcasts not showing up on clip.

When dragging and dropping podcasts (MP3) to the “Podcast” folder on the clip using Explorer, Explorer shows that the files are on the clip.  When disconnecting, however, the Clip itself fails to see any media on the device.  I have tried to move the files to various Folders (Music, Audiobooks) and occasionaly, one of the Podcasts will show up (always the same one but intermittent). 

I have updated the Firmware and verfied that the tags have artist, album and title information.  I have also verified that the Genre in each is set to “Podcast” 

Any ideas what I need to do to get this to work?  Any help would be appreciated.

oh wow.  I know I just posted this but it seems that I have managed to “fix” the issue by changing each of the genre tags to “Other”.  All three are now showing up.

You may want to try formatting the Clip under its Settings, and see if that helps.  Note:  that will erase any content you have on the Clip.

I tried formating as well.  First under settings on the clip and then using Windows Explorer.  Neither worked.  It seems odd to me that something as small as a Genre tag would prevent an MP3 from showing up, but that seems to be the case.

It’s especially odd because, you should not even have to set the genre in the Podcasts folder. 

I wonder if, by any chance, there might have been an issue with the tag, such as a typographical error–you might want to apply it again.  At one point, I had labeled some podcasts as Podcasts, plural, and they either showed as unknown or didn’t appear.  I also have had success with opening problematic files up in MP3Tag and resaving them without any changes–seemingly, that fixed something unseen (perhaps the tag coding that the producer had used).