Please help quick! Sansa Fuze can't see files

I got a Sansa Fuze 4GB for my little cousin for xmas I loaded music on it on my mac just by opening finder, opening sansa, and copied the .mp3’s into to the music folder. Yet they’re not showing on the fuze or when I look in the folders on my mac yet it says there’s only 25mb left and 3750mb filled. How I find them or delete them and try again? I only have a few hours to do this for him! Please help me thanks!

First of all, go into Settings/System Settings/USB mode and put it in MSC. The other mode, MTP, is for Windows Media Player, not for Apple connection. See if that makes the files visible.

Now, two possibilities:

  1. Are you sure they are .mp3 files and not Apple’s own .aac, .m4a or .m4p files? The Fuze won’t play those, or show them.

You can open your music library in iTunes, highlight an album (or albums) and under Advanced click Create Mp3 Version. That will make mp3 copies. (You’ll need hard-drive space–they are duplicates, not replacements.)

To clear the Fuze fast, go to Settings/System Settings and Format. That erases everything you’ve added at once.

Then send over the .mp3 versions.

  1. If they are really mp3 files, then the tags might be the wrong version. The Fuze doesn’t read ID3v1, only ID3v2. Somehow you need to change them to ID3v2.3 (and ISO-8859-1). My Windows version of iTunes won’t do this, but maybe yours will–look in Advanced and also in Edit/Preferences/Advanced.

However, you should still be able to see mp3  files if you go to Music and scroll past Album, Artist, etc. to the second page and look in Folders

Or Google around for Tag Editing software for Mac.