Music files will not show up on PC

Music files that are not in a folder will not show up on my PC. I have a lot of music files that I loaded with a Mac as mp3 files, and some that I ripped/loaded from cds and put them into folders, but a PC can’t see the mp3 files when I open the device as an external drive, and media players won’t see the files either. I’ve tried both USB types, but neither work.

The files play fine on the device, but won’t show in any folders on a PC. 

Any help would be appreciated. Thanks.

work them on Windows XP computer for a try!

Work it on a Windows XP system for a try.

Click on My Computer. Tools/View/Folder Options and check “Show hidden files and folders” and, for that matter, un-check “Hide extensions of known filetypes” in case the Mac put in some unknown kinds of files. Maybe the Mac made something the PC sees as a hidden folder 

Go to Settings/System Settings/USB Mode and change it to MSC.

Your computer can only see files in one mode at a time, MSC or MTP. Your Fuze was probably on Auto Detect. 

Auto Detect looks for Windows Media Player (10 or later) on a computer and puts it in MTP mode if it’s there.

There’s no WMP on your Mac, so it sent over the files in MSC. And when you put it in MSC, your PC will see the files too. 

Message Edited by Black-Rectangle on 07-29-2010 01:34 PM