Playlists just dont work.....:(


I have a 4GB clip, and I tried virtually everything to get m3u playlists to work…absolutely no luck.

I have:

-installed the latest firmware 

-edited the m3u files to have relative paths

-experimented with substituting backlashes wis slashes and vice versa

I connect the clip to an ubuntu system.

Any help??? Maybe a sample m3u file that is supposed to work? (I can make the filenames match) 

Without playlists, the whole thing is pretty useless to me.

Another thing for the wishlist: Make that volume control more responsive. If a music piece comes up that is too loud, i want *quick* volume response before i blow my ears out. Even better, build the next version with a rotating knob/wheel!! Yeah, that’*s *basic* user-friendliness!!

But if you retain the (cheap) digital up/down volume control,  how about *not*  putting the on/off switch directly opposite to it on the player, where one is forced to grap the miniature player just trying to adjust the volume?

Uhu. Absolutely basic ergonomics… I know that the competition is often worse, but these few things alone would make me grade this player at a deserved ‘F’.

Don’t hire me. I’d make life miserable for your engineers, and mostly your designers. I would, however, turn out a totally usable product…:wink:



Try here for example m3u syntax.

But first, check your text editor’s EOL (end of line) character settings as the m3u parser may be looking for CR+LF (0x0D0A)and *nix text files are normally LF (0x0A) terminated…

EDIT: I just verified that UNIX EOL formatted m3us won’t fly, using a copy of a working playlist, saved with UNIX mode EOL.

So if you hand-edited them under Linux (to create the relative paths), the text editor most likely saved it with LF only, and you’re chasing a ghost.

BTW I can “see” the playlist itself on the Clip but it shows “[EMPTY]” when I should see the selection listing…is this what you are experiencing, or something different?

Please share with us the symptoms of your problem!

Message Edited by Click on 07-01-2008 12:47 PM

I tried using playlists through the “Select all”, right click, and “Create playlist” feature, but some of my playlists didn’t display any songs on my Clip.  Since I had ID tagged all of my mp3s with MP3Tag before hand, I just use the “Albums” and “Artists” lists to listen to my music.  I miss browsing and organizing by folders, but the Clip’s other features are just too good to pass up.

@sriajuda - try searching this forum and the Fuze forum (playlists work the same on both).  m3u file defintely work, but as mentioned, they must be standard ASCII/DOS style text files with CRLF line separators.  Coming from Linux, it’s likely that your files are Unicode and only have LF.

Sriajuda -

I have an e280v2 player that I was having problems with getting a .m3u playlist to work also. I finally, after much hair-pulling and more than a little cussing, had success with Winamp. Check out this thread, where I tried to explain what I did and help someone else with the same problem with a Fuze.

The e200 series v2, the Fuze & the Clip all seem to use .m3u playlists vs. the .pla format I was used to on my e260v1 player. Read through the entire thread as my first suggestion (post #9) was slightly incorrect. I tested the procedure and sucessfully created more playlists that worked. I described this in a follow-up post (post #14). Just remember to save your playlist in your MUSIC folder and NOT in your PLAYLIST folder on the player. Yeah, I know, sound kinda counter-intuitive, doesn’t it?

Like I said, I know this works on my e280. Hopefully, it will work for you & your Clip too. :smiley:

Message Edited by Tapeworm on 07-02-2008 06:53 PM

I found .m3u files only work when I place them (with relative paths…aka no path info) in the same folder as the .mp3 files themselves.

(4G Sansa Clip, v01.01.18A firmware)


Message Edited by gpenguin on 02-22-2009 11:19 PM

*** SOLVED ***

UPGRADE YOUR FIRMWARE!  I just updated from .18A to .30A and now playlists work just fine.


Message Edited by gpenguin on 02-22-2009 11:33 PM