Player won't switch on/PC won't recognise

Hope someone can help with this. Got a brand new 8GB Clip Jam out the box today, connected to laptop - everything looked okay at first, charging message on screen, device recognised etc.

Before I got a chance to transfer any files, the player disconnected from PC. Tried reconnecting to multiple PCs but now will not show up, and cannot even get player to switch on. When I press power the Sandisk logo shows for a few seconds then nothing…

When the usb cable is connected, the Sandisk logo shows permanently, but no sign the device is actually charging.

Have tried resetting the player multiple times, but same thing keeps happening. Any suggestions of how to fix this? 

Return it and get another. Most likely a dud.

Did you try a different usb cable? Are you using a rear usb port if you have a desktop, or plugging in a notebook before connecting the player? If not, the usb port might be putting out very low power. Are you connecting the player to the usb port directly, and not through a hub or usb extension cable?