OS X Mojave - Can't select Extreme Pro External 1TB as startup disk or start up from it

Hi, I bought this SSD to install and run a different version of OS X on my Mac Mini 2018. They come with those T2 security chips, more on that later.

First of all, my Mac Mini running Mojave 10.14.6 (up to date) detects the SSD. It shows on my desktop when I connect it and I can transfer files to/from it with no problems.

I’ve successfully erased the SSD and transformed it into an APFS drive. I’ve also successfully installed OS X Catalina on it (The SSD showed on the install menu) but when I’ve tried to reboot from it or I try to restart from it (holding Command+R on startup) or select it as a startup disk before restating, the SSD doesn’t show on those menus. I’ve tried enabling “Boot from external drive” option on Startup Security Utility menu but it still doesn’t work and the SSD is nowhere to be seen on those menus I’ve mentioned.

On this link it says that the newer SSDs come with ROMs and they should have the latest firmware in order for Macs with T2 chips to see them: https://support.apple.com/en-us/HT202796

But I couldn’t find any specific firmware for mine (SDSSDE80-1T00-G25 I believe)

So I’d be grateful to anyone with similar experience or a solution for shedding some light to my problem.