Macbook Pro won't recognize internal Extreme 240

15" Macbook Pro (5,1 late 2008)
2.4 GHz Core 2 Duo/4 GB
OS X 10.8.4

I think I have done everything I can according to what I have read and I am left mystified. I purchased a new SanDisk Extreme 240GB SSD through Amazon to replace the Intel 80GB SSD that I have been using as my boot drive and which is installed in the optical drive bay.

• I removed the original HDD (working perfectly and used for storage) from the hard drive bay and installed the Extreme: no sign of it in System Report/Profile or Disk Utility.

• I swapped the Intel out and put the Extreme in the optical bay. It booted fine from the Intel in the HD bay but still no sign of the Extreme.

• I tried both configurations with PRAM and SMC resets: still nothing.

• I bought a 2.5" SATA external enclosure, popped in the Extreme and voila! “You have inserted a disk that can not be read yada yada yada” FORMAT SUCKA!  I was able to install Mountain Lion on the Extreme, boot from it, and run through the set-up/registration and view the joy that is a completely fresh OS X install, just not physically where I need it.

  • Once again tried it in the hard drive and optical bays… no sign of it whatsoever. :frowning:

At various times I have run the Extreme 240GB Firmware Updater version R211 from my external optical drive. It sees the Intel SSD but not the SanDisk.

So I have successfully installed OS X on my Extreme SSD and can boot from it as an external via USB but I can’t use it internally. I am now back to my original configuration (working just as it did before) with the Extreme in the external enclosure mocking me.



Sorry to hear that but the Nvidia MCP79 chipset is known to be faulty and i remember that even apple replaced some of these laptops with this chipset. None of the ssd will work properly with this one so i would suggest to change the chipset to use the drive normally.