Only playing radio


I just bought a clip zip for my mother as a gift and I seem to be having some problems.  Everything seemed fine initially, then I went into radio to set her favourite stations and I couldn’t back out to the main menu.  I’ve tried holding the back button and it is non-responsive. I have updated the firmware with no change.

Any suggestions? What am I doing wrong? Thanks for your input.

1 Like

Have you tried a hard reset (hold the on button down for 30 seconds or so)?  That might help.

1 Like

Press the BACK or HOME button once, then press the right or left buttons (3 or 9 o’clock positions) to scroll to the other MAIN menu items.

Note, unless you pressed the PAUSE button (12 o’clock position) before doing this the radio will continue to play until another option is initiated (like selecting Play All or a song in the MUSIC menu).

I have tried the hard reset with no change.  I have tried pressing the back button once and it doesn’t go to the main menu at all, no change, it stays in the radio section.  I have tried pressing and holding the back button with the same result.

Just a check, just in case (and, it happens): When SanDisk ships players out, there is a clear plastic screen protector over the display, which has a screen image painted onto it. Have you removed that? There usually is a small tab at the lower right of the screen protector to help with that.

Yes, it has been removed.  I charged it after removing it from the box, checked firmware, put some music on it, then set the radio presets.  Now it plays radio and will not leave the radio section. I can change the radio stations, change the presets etc but cannot leave the radio to go to the main menu.

I have exactly the same problem and have also tried to suggested fixes to no avail.  When I first received the player the other categories were accessable.  When I did presets on certain radio stations I have never been able to get it to go anywhere else

Go to your Settings menu. Press Select button and then select System Settings. Scroll down to Customize and select that. Make sure your other Main Menu items (Music, Book, Voice, Card, etc.) say ON. If not press the Select or the right button to turn them on. Then they will be visible and available to you.

I cannot go to the main menu.  It is stuck in the radio section.  I cannot leave it.  I had a friend tell me the internal contacts for the buttons on hers were not directly below where you would press, and she had to try pushing at different angles on the right direction button and the back button to get the them to work.  I will try this when I next go over to my Mom’s house.