"No song" when music is on external SDHC card

Simply put - my Clip+ gives me the “No song” error when I have music on the external memory card.

My old Clip+ had many issues, so I got another. The SDHC card I used in the old one (Gskill 32gb micro SDHC) worked perfectly, and is the same one I’m using with the new Clip+.

(I don’t know if it’s worth mentioning, but the old one has “Sansa” on the front and the new one has “SanDisk” on it. Maybe slightly different models?)

I updated the firmware on the new one with no issues.

The device is set to MSC mode. It recognizes the SDHC card in the info menu (and properly updates the available space). All of the files I’ve been using are properly and fully tagged with ID3 tags, and they are all MP3s.

The same exact files work perfectly fine when I play them from the internal memory.

I tried deleting the files on the SDHC card (using my computer), and re-copying them to the MUSIC folder, with no luck. No matter what I do, I keep getting “No song” when trying to play or search for files that are on the card.

Files continue to work fine when the external card is used with my old Clip+, and I am able to use it in other devices, so it’s not the card itself.

I have tried the solutions listed on this page, and that didn’t fix it.


I’m not sure what else to do, and I really don’t want to be out $85.

Is this new player actually “new” or did you buy it as a re-furb? The Clip+ has been discontinued for somoe time now, and availability is scarce (and expensive). Re-furbished players (actually all electronics) are risky as they have been previously returned, ususally for some problem or defect and then sold off in bulk to refurbishing companies. Many times the original defect or issue is never resolved.

Either way, sounds like the card reader in the player is wonky. If you have any warranty or exchange options with whomever you bought it from, I would take advantage of those.

Thanks for the reply!

I bought it from Amazon, and it was advertised as new. It came in original packaging with everything included, even the sticker on the front. I’ll have to look into the seller and my options if I can’t figure it out, but I want to absolutely exhaust anything possible.

I did forget to mention something (probably important, go figure), now that I re-read my post -

The very first time I opened it, and turned it on to try it out - I put the card in , and it actually did work, once.

The intent was to leave it running overnight to run the battery out (it was at like 75%) and then give it a full recharge.

When it was dead, I took the card out and plugged the Clip into my PC to charge. After that is when the problems started.

Edit: Could the firmware be affecting it? I had updated it after the problems started in the hopes that it would fix it, so I’m not sure.

You might try formatting it; sometimes that can cure stubborn issues. Go into the Setting menu; there’s a Format option. Note though, that formatting will erase any/all content you have put on the player so you will have to transfer any music, etc. over to the player again afterwards. It will not affect the firmware & you should do this with the card out of the player.

As a step #2 if this doesn’t seem to help, you could re-format the card. Again, this will erase everything on the card. I don’t remember if the player can format the card, or if you’ll have to use your computer. But given the fact that these files on the card still work in your older player, this may not be necessary.

Let’s hope formatting the player solves it but Amazon, regardless of whether they sold it or one of their vendors, does offer a generous & easy return policy should you have to resort to that.

Let us know how it goes . . .


Btw -

“The intent was to leave it running overnight to run the battery out (it was at like 75%) and then give it a full recharge.”

This is unnecessary with the Lithium-Ion batteries in these things. They have no ‘memory’ like the older Ni-Cad type batteries; you can give them a quick boost of any duration without harming the battery.

“Similar to a mechanical device that wears out faster with heavy use, the depth of discharge (DoD) determines the cycle count of the battery. The smaller the discharge (low DoD), the longer the battery will last. If at all possible, avoid full discharges and charge the battery more often between uses. Partial discharge on Li-ion is fine. There is no memory and the battery does not need periodic full discharge cycles to prolong life.”

You can read more of this article on Li-Ion battery care here:


1 Like

Thanks for the response; here are the exact steps taken:

  1. Remove card
  2. Turn on device
  3. Format
  4. Turn off device
  5. Insert card
  6. Turn on device - “Refreshing your media” pops up
  7. Music - Play all - “No song” still comes up
  8. Settings - System Settings - Info - check SD card
  9. 29902/29919 MB free - I only have 2 songs on the card at the moment for testing, and it recognizes that they are taking up space on the card.

There doesn’t seem to be an option to format the card from the device;

  1. Turn off device

  2. Plug into PC (with card still in it)

  3. 2 separate Autoplay windows for both the internal and external memory pop up, close both

  4. Right click Removable Disk H (29.2 GB) - Format - FAT32, default allocation size, no quick format (Edit: I tried the same steps with a quick format, same result)

  5. Eject external drive, then Clip

  6. Unplug device from PC - “Refreshing your media” comes up

  7. Turn off device and then back on

  8. Check settings, info shows 29918/29919 MB free

  9. Turn off device and plug back into PC, 2 more AutoPlays pop up

  10. Copy one MP3 file into the root folder, and a different one into the MUSIC folder - this way I will know where it’s playing music from, if it’s able to

  11. Eject both again, and unplug device

  12. “Refreshing your media” again

  13. Turn off device, and then back on

  14. Check settings - 29902/29919 MB free

  15. Music - Play All - still getting “No song” - all possible options (artist, album etc) come up Empty

 Edit2: I put the card back into my old one again, and it plays both files just fine.

Try switching your USB setting on the player. If it’s set to MTP, switch to MSC. If It’s set to MSC, switch to MTP. Don’t use the Auto setting.

Yeah, it’s still set to MSC.

Different approach: do you think Rockbox might solve it? I’d be able to remove it and factory reset if not, and probably return it at that point.

I doubt whether Rockbox would make any difference, but you could always try.

Alright, I’ll give it a shot.

In the meantime, is there anything else we can try?

I don’t want to leave it unsolved, even if I do end up returning it.


Rockbox seems to be working with the external card.

I have no music on the internal memory, and it’s playing all the music on the card fine. It’s a bit weird to get used to but at least it works…

I also tried booting back into the original firmware (by holding the left button while powering on), and still got the same result as before - “No song”.

So, would this mean it’s a firmware issue? Since Rockbox is just replacement firmware…