No image in ID3v2.3 tags !

Hello !

I’ve tagged my mp3s with their images (albums covers,… and they are less than 100Ko).

To do this, i use Easytag (under Linux). 

Well,… the tags are displayed, except all the images.

 I’ve tried all options for Easytag (Iso encoding,  compression, crc32,ID3v2.4, with and without ID3v1…) but images are NEVER displayed !

I’ve also the latest firmware (22).

So, … any idea please ??? 

Some have problems with embedded art within the ID3 tags. You can also add a separate .jpg image of the cover art to the ALBUM folder. Name it ‘album art.jpg’ or ‘folder.jpg’. This, while being an extra step will make the cover art display while the song is playing on the Fuze.

I’ve had problems with album art when the art was too large (I don’t remember how large that was; I now standardize on 200x200 which I think is sufficient) or the JPG was flagged as “progressive” display rather than standard.

Hi,

I use EasyTAG 2.1.4 from the Kubuntu 8.10 repository for all my tagging.

I have it set to write only ID3v2.3 tags with ISO-8859-1 charset. I don’t write ID3v1 tags. I don’t have CRC or compression set. AFAIK, Sansa players don’t understand ID3v2.4 at all.

To get embedded art to work, I use a jpg of 200x200 pixels or less, and <20kB in size. I don’t know what the actual limits are - I haven’t bothered experimenting that much. But if I use large® jpegs, it seems not to work.

If you’re bothered about Fuze’s ‘Display Art in Lists’ setting working, I think you need to put a Folder.jpg in the album’s folder. As Tapeworm says, this will also get picked up as album art.

On a different issue with EasyTAG, the Fuze seems not to recognise  some genre tags written by  EasyTAG. There is nothing wrong with the tag itself, since it is read fine by other players & apps (WMP among them). Indie & Folk are some that the Fuze fails to understand.

Edit: I’ve just checked - and I have one image of 35.3k 200x200 that displays OK. 

Message Edited by daytona955 on 12-27-2008 12:00 AM

Thank you for yours answers !

In fact this was an issue with Easytag : i’ve made my tag on  ID3v2.4 version.

The problem was to convert then in ID3v2.3 with Easytag.

So i’ve to and an text tag AND remove the image for each album, and then remove this text tag and put back the image to be sure that it’s recorded in 2.3 format.

Finally, i’ve choose the second way : copy  “folder.jpg” in each album directory : more easy and more efficient !

Now… it’s time to have fun with my Fuze ;-))))))