New SSD suddenly started freezing BIOS POST

Hi all,

Hope someone can help or at least point me in the right direction.

I recently bought an Ultra Plus 128Gb SSD to be my main drive replacing an old Maxtor IDE HDD drive and I already have a 320Gb SATA HDD drive for my data. Rather than mess around I decided on a clean install so removed the old Maxtor. I added the new SSD to my MB and on booting the BIOS immediately found it. I was able to install Windows 7 to the SSD… and the world was a happy place.

Yesterday something odd happened. When rebooting, usually the BIOS lists the discovered drives in order: A DVD-RW (IDE port 1 Master), a CD-RW (IDE port 2 Master), the new Sata SSD drive (Sata port 0) and lastly the other Sata HDD (Sata port 1). At this point it would normally boot Windows 7 from the SSD… But this time the machine froze after displayting the SSD drive information. It didn’t show the information for the other Sata drive, any other message or complete POST - just froze.

If I remove the SSD then the BIOS completes POST and tries to boot an OS from the other Sata drive/DVD etc.

Starting to go mad I checked everything - removed all drives and tested every connection. It seems that with the new SSD connected to either Sata port the POST freezes.

If I disconnect the SSD, boot into BIOS settings, reconnecting the SSD and rediscovering the Sata port then it will find the drive BUT it reports in the BIOS that LBA Mode is supported but Block Mode is not supported. This used to report a block size - just like the Sata HDD. Sounds like something is definitely adrift somewhere…

The drive is running the X2306RL firmware which it was supplied with.

Any ideas greatfully received. Thanks!


Just thought I’d update you all…

Worked with SanDisk support through the usual checklist. Checked MB operation by replacing SSD with spare Sata HDD and everything worked correctly on both Sata ports. Seems the only answer is *something* wrong in the drive.

Have requested replacement from the supplier (Amazon) so that *should* be the end of the matter.

I think it is the known firmware bug with 2306. When you wait long enough, the bios will continue post, but then not find the ssd. Updating to 2316 will help. But some users reported problems doing so, resulting in a corrupted drive. This is why the firmware is not updatable through Sandisk toolkit.

So if the replacement drive shows the same errors an update might help. Anyways good luck!