Disconnecting Drive from Bios


I have been using my SanDisk Ultra Plus SSD 64GB for about 2-3 months now from brand new and everything has been great. However since last night I have had the issue (which some others have also had) where the drive/device is disconnecting from Bios. I use it to run my PC so it has Windows 8 on it and unfortunately means I cant use my PC anymore. 

I have tried various methods to get it to work now, it was orignally set to IDE mode on my bios which was working just fine, but I was told that it should be set to ACHI mode instead. 

So what happens it that it finds it in Bios from a cold start, starts to load Win 8 but before it loads to the login screen it hangs on a blank screen and then comes up with an error along the lines on “failed to start…couldn’t find winload.exe” or hangs for 5 minutes and then says “Crital_Process_died” BSOD

The next time I restart the computer the SSD has disconnected/disapeared from bios and unable to load. Yet again from a cold start it finds it and attemps to load again.

I have tried several different methods to get this to work now and none seem to be the answer. Updating the firmware manually comes back everytime saying it failed. Im not sure what I am supposed to do or try at this point. I think the last option now is to get it replaced… 

Any help or solutions on this matter would be greatly appreciated!

Kind Regards


I managed to get it to load temporarily, if i try to read/write to the drive is disconnects, can’t update the firmware sadly as it fails. But here is the exported data from SanDisk SSD Toolkit:

"Model","SanDisk SDSSDH2064G",,,,,, "Serial Number","130573400584",,,,,, "Firmware Revision","X211200",,,,,, "ATA Major Version","ATA8-ACS",,,,,, "ATA Minor Version","ATA8-ACS version 6",,,,,, "SATA Generation","3",,,,,, "Worldwide Naming","5001B449725CF608",,,,,, "Supported Features","DSM (TRIM), SMART, Security, NCQ, APM",,,,,, "","","01","Raw Read Error Rate","100","","0","N/A" "","","05","Retired Block Count","100","","0","N/A" "","","09","Power On Hours","166","","166","N/A" "","","0C","Device Power Cycle Count","100","","47","N/A" "","","AB","Program Fail Count","100","","0","N/A" "","","AC","Erase Fail Count","100","","0","N/A" "","","AE","Unexpected Power Loss Count","100","","18","N/A" "","","C2","Temperature","69","","31","N/A" "","","E6","Life Curve Status","100","","","N/A" "","","F1","Lifetime Writes to Host","253","","2075493748","N/A" "","","F2","Lifetime Reads from Host","253","","782846051","N/A"

is the FW update fails something is wrong with the SSD. COntact sandisk support for warranty replacement.