New Sansa Clip+ won't activate in Audible Manager

I have recently bought a new Sansa Clip+ (I have several). I have been trying to activate it in Audible Manager and keep getting sent around in circles. I choose “Activate device”, then I am directed to the webpage to put in login & password. When I hit continue I am returned to Audible Manager with a pop-up box again which say “To activate your Sandisk SansaClip+ please press ok”, which sends me back to the login/password page. It goes around in circles without actually refusing to activate it , but not activating it either.

I have tried:

  • AutoDetect, MTP & MSC  USB options. 

  • updated the sansa clip+ firmware to V01.02.18A

  • re-formated my Sansa Clip+ device

  • deactivated an old sansa device, (in case I havd hit the limit of 3 devices), deactivation successful

  • deleted the Audible folder on the device already & tried to re-activate

  • updated & re-dowloaded Audible Manager & Audible Download Manager

  • changed my computer regional settings to USA (I’m in Australia), so I was redirected to the activation page (rather than the activation page)

  • updated my password & login for my account

What else can I try? 


Try contacting Audible?