Netlibrary problems

I attempt to download books from Netlibrary (Download Manager or Media Center).  It looks like it’s going through an appropriate download.  It says that it is downloading to personal device.  The bookname/book does not show up on my Clip afterwards.  I can find it on the clip files (under internal memory in “EAudiobooks”) but I can’t find the Netlibrary books on the device itself.

I can download IPod compatible books from Netlibrary to my IPod.  I can download books to my Sansa Sandisk e250 (but I detest that device as I’m always losing my place and having to start at the beginning).  I tried my dtr’s 2GB Clip and it also doesn’t show the books on the menu though it’s in the Clip’s files.

Help!  How can I find the books???

Your Clip has to be in MTP mode for DRM-crippled NetLibrary files. _ Not _ MSC and _ not _ Auto Defect.

Unless they have the Audible extension .aa or are labeled as Audiobooks as the Genre in the ID3 tag, they may get put in the Music folder on the device.

Thank you.  Now I can find them.  I didn’t even know what the system settings were!  It’s not in the product manual.  I wonder why not?  Thank you again.


Guru, You’re so smart–can I ask you another question?  About my Sansa Sandisk…Is there anyway not to lose your place in a book?  Sometimes when I pause and turn it off (like hoping into Starbucks), when I come back to the car I have to start it at the beginning again.  Then when I try to forward it, it is ok for about 1/3 of the track and then boom it goes all the way to the next tract!


Actually, I was able to update my sandisk and I think they have fixed the fast forward problem.  Now I can download my Netlibrary to Sandisk.  Once again I can’t access the Netlibrary books on my Clip.  I switched the system settings to MTP.  The books were there but then disappeared.  Guess there’s a reason the Clip was rather inexpensive.  I think it’s doomed for the garbage!

Your computer can only see files while connected in the same mode as which they were transferred in. In other words, if they were transferred in MSC mode, you can’t see or access them while connected in MTP. And vice-versa.

Secondly, when you perform a firmware update, the player reverts back to the default Auto Defect mode. This will connect in MTP if possible, but if not it will connect in MSC. So you have to manually select your mode of choice after a firmware update before loading anything more onto the unit, otherwise you’re in for a state of confusion.

Now that you know the ‘ropes’, I’d suggest formatting the player, which will erase everything you’ve put on it and start over using the correct USC mode.

Your player has a book-marking feature for audio books, but if they are in the Music folder and are .mp3 format it thinks they’re music and the book-marking feature won’t work.You may have to manually transferr them over to the AudioBooks folder and/or change the Genre in the ID3 tag to ‘audiobook’ (without quotes). MP3TAG can help you with this.

By the way both the Audio Book Options and System Settings are explained in the User’s Manual on pages 24 - 26. :wink:

I’m having this problem as well. Setting to MTP and reformatting it was able to transfer the file (but Window media indicated it converted the file before transferring). When I try to play the synced file on my Clip 2GB, there is no sound. The file works fine on my PC.

Problem solved. I had downloaded the ‘radio quality’ file from NetLibrary, but must be ‘cd quality’ to transfer to Clip.