Audiobook loads backwards on my Clip +

Using NetLibrary I get successful downloads to the Clip+ but when I go to play the book loads all of the chapters then goes to the last chapter then won’t play.  

I have the exact same problem and the customer support was not very helpful (and took 2 days to get a reply).  The other day, I found a place to list the books in ascending order which worked fine for one book, but not the second.  The user’s manual is next to useless! 

2 words . . . ID3 tags.

Use the search function here.

Have you searched for NetLibrary on this forum and tried the obvious suggestions, like MTP mode?  Since you say the tracks don’t play, you may have a problem with the DRM files.

It does sound like the track numbers are not set on the audiobook files.  I’d think NetLibrary would be a reliable source, though (I haven’t ever gotten bad track numbers from except when I had a bad download & redownloading fixed the track numbers).

Good luck & give more details if you still need help.  I know there are people on here who successfully use NetLibrary so it can be done.  My library happens to use so I’m not much help.

i have experience this before with Netlibrary. I was able to transfer the books to my Sansa using Media Center sucessfully but the books will just skip. Connect your player to your computer and look for those books and check if the have file extension (.mp3 or .wma). If the File Type under Properties says “File” only, then it is a problem with the book. Try other books then.