Downloading from NetLibrary to Sansa Clip

I have two Sansa Clips. I have downloaded the Firmware Update to each of them. When I download audiobooks from NetLibrary they play on my computer. The books show as loaded into the Sansa. When I play them on the Sansa the timer goes as if they are playing, but I get No Sound.

Can anyone help please.

You have to use MTP mode and Sync the content using WMP

On the player,  go to Settings>USBMode>MTP  (or Auto) 

 Connect to XP or Vista.

Play the song in WMP11.

Sync the song to the device.

Message Edited by sansafix on 10-02-2008 03:55 PM

Thanks, it was a good thought, but I did use MTP mode when I downloaded the books from NetLibrary.

It’s not clear what order you did everything in.  I had a problem with a Netlibrary book not playing after transfer via MTP to the clip, I then tried playing it in windows media player and it worked.  After I synced the netlibrary book back to the clip it did play.  What apparently happened was that WMP pulled down the license file for the book when I tried playing it, so then when I transfered the book the second time WMP had the license info to send over as well.