My Fuze won't turn on

I was listening to music and all of a sudden it stopped playing. I thought that it might need to be charged, so I plugged it in. It still won’t turn on and my computer doesn’t recognize it when it is connected. Is there something I can do, or is it broken?

Your Fuze needs to be reset.  Slide the power switch to the ON position and hold it there for about 20 seconds.  The device should power up normally after that.

It will also connect and charge.


I had a similar problem… My battery died, so I plugged it in. When I saw this post, I tried it but it’s still not working. Is there any way to fix this or did i permanently mess up my battery?

Rechargeable batteries do eventually give out. How old is the unit?

Also, are you connecting it directly to the computer (not a hub)? Ports closer to the back of the computer are best, because they provide more power.

What does the unit show when you connect it?  

My Fuze is about 6 months old. It’s connected directly to my computer, but the USB ports are on the front. When I connect it, it doesn’t show anything.  

I’m a little confused. I tried the soft reset several times, without it working. I just tried it again for the 6th time, and it connected to my computer. (it was already plugged in) It’s been plugged in for about 12 hours, could it have been charging even though the screen wasn’t showing? Sorry for the trouble, anyway. 

After one hour, the screen will turn off when charging.  If the Fuze was “frozen”, it will appear to be dead, though it’s actually only “stuck”.  Resetting the device by the soft reset should do the trick- hold the power switch in the ON position for 20 seconds and the device resets.

Once reset, the Sansa should power up and charge normally.