My Clip doesn't shows my forigen language song title properly

Let me start off with my Computer settings.

I am running on Windows Home XP2 (English Version), and WMP 10

First of all, my comp didn’t recognize the Clip in MTP mode, but MSC mode works. So, that is not a big deal to me.

Secondly, I can sucessfully transfer songs into my Clip. However, my Chinese (Tradiontional Chinese characters) and Japanese Songs’ Title, Singers’ Name, and Albums’ Title are not showing properly.

I am editing the songs’ titles, singers’ names, and Albums’ titles by Right-Click the mp3 > properties, and edit in there. Anyone help?

Hi there,

If your songs are unicoded, then it should work.  If your songs are coded differently other than unicode, it might require some regional settings.  So you might want to change your Regional Settings to Chinese instead of English and try again.  I think that might do the trick.  Here are the steps to change your regional settings.

Click Start --> Control Panel --> Date, Time, Language & Regional Options --> Regional & Language Options

Here you will see 3 tabs:  Regional Options, Language, Advanced

So you change the Regional Options to your desired language (i.e. Chinese) & go to Advanced to change to Chinese also.  Then you will have to restart your computer.  Then after that you should be able to transfer the songs & be able to see the character properly.  Please try it out and let me know if it does not work.

Make sure the source files on the PC aren’t write protected.  This would prevent the ID3 tag changes from being saved.

It doesn’t work. I’ve ensured that the Files are not write protected, and changed the language and all.
Any Other suggestions?