MP3 audio files play too fast

I have been using my Clip to listen to podcasts and audio books for a couple of years. All of a sudden all of my readers are chipmunks! The files sound fine on my PC (windows 7). I am updated to 2.01.35 but the problem did not seem to start when I did the firmware update.

BTW my music files seem fine

If you haven’t already, first thing I’d check is to look under Settings->Audiobook Options->Speed and make sure it says “Normal”, not Fast. 

Possibly also try a reset?

Thanks for the help but I did not see an audio book setting

The reset did the trick. I am not sure why they have a play it fast option…I am just glad it is turned off.

The reset is a good and helpful thing.    :slight_smile: