Micro SD XC Issues - Can't Read Video Files

Please forgive me for being a noob here on this forum. I did a search and couldn’t find any info on my issue, so I’m posting here now… :smiley:

I’m having trouble writing video files (MKV, MP4, etc.) to the external micro SD XC card that I’m using with my SanDisk media drive. The first few files that I write onto the SD card transfer and play fine on the media drive and my PC (I’m using VLC). After about 10GB or so of data has been transferred to the card, the files copy over, but they won’t play. VLC tells me that it does not support the video format “undf”.

I’m using a SanDisk 64GB micro SD XC card spec’ed to 30MB/s (formatted as exFAT). I have two of these cards and they both behave the same. I’ve also tried 128GB HC (formatted NTFS) cards to the same result. Nothing seems to work as expected. What am I doing wrong or missing here? I’ve been battling this issue for weeks and its driving me nuts!!!

1 Like

if the same videos are copied to the internal memory do they play?

when you have videos on the card past the 10GB mark that will not play on the WMD app can they be played from the card using the computer? 

@drlucky wrote:

if the same videos are copied to the internal memory do they play?


when you have videos on the card past the 10GB mark that will not play on the WMD app can they be played from the card using the computer? 

Yeah, if copied to the internal memory from the original source drive they play fine. If copied from the SD card to the internal memory, they do not.

Files past the 10GB point don’t play from the card on the computer. 

I know that the source files located on the computer are good. They are not corrupt before being copied to the SD card. 

are you sure the cards you have are authentic? corrupting files past a certain capacity is a common issue with fake cards. 

Both cards came in what looks like authentice packaging. Is there a way to tell if they’re real SanDisk cards or not?

where did you purchase them from? packaging for fake cards look pretty real these days. you can contact sandisk support and they can help with authenticating the cards. 

Ebay. OK, thanks.

So, just to be clear, it doesn’t seem like other people are seeing this issue and it’s most likely card related?

ebay is full of fake cards. that is likely the issue since the videos will not even play on the computer it seems the issue is card related not WMD related. 

you can also test the cards yourself. there is a program called H2TestW (google search for it) that can show you if you have a fake card. the program will write to the entire card then go back and verify the data. if the card is fake you will see the verification fail at some point. typically the fake cards have some amount of storage probably like around 8GB but the partition is spoofed to make it look bigger. of course any data written past the actual capacity of available storage will become corrupt. you ill see that in H2TestW as verification failures. 

Hey, just wanted to say thanks for your help! Apparently, I have counterfit cards. :cry:

I’m running H2TestW now to see what state one of the cards is really in. I’m thinking it may be spoofed as you stated. The partion looks funny to me. It contains a 16MB unallocated partion that’s never seemed right to me from the start. Could that be where the spoofing code is located? 

TO be honest I am not sure exactly how they do it. I only know what to look for after being burned a few times and reading some on the net about fake cards. I only buy cards from authorized resellers now and if the deal looks too good i pass it up. 

…and here’s the data from H2testw…only 7.8GB of space available on a 64GB card!

Warning: Only 63980 of 63981 MByte tested.
The media is likely to be defective.
7.8 GByte OK (16411699 sectors)
54.6 GByte DATA LOST (114619341 sectors)
Details:0 KByte overwritten (0 sectors)
0 KByte slightly changed (< 8 bit/sector, 0 sectors)
54.6 GByte corrupted (114619341 sectors)
0 KByte aliased memory (0 sectors)
First error at offset: 0x00000000008f2000
Expected: 0x00000000008f2000
Found: 0x00000200008f2000
H2testw version 1.3
Writing speed: 7.13 MByte/s
Reading speed: 16.6 MByte/s
H2testw v1.4

That is an 8GB card with a spoofed capacity to make it look like a 64GB. Typical for fake cards. I would contact the seller for a refund and report the seller to sandisk.