Memory Card not working on SansaFuze

I put a pny 8gb memory card in my 4gb SansaFuze.  My computer read it just fine and I synced a few songs.  They loaded and it worked great.

Then, I synced a playlist with several hours worth of songs (a playlist) onto the card.  It seemed to be going fine until it got to the part where it is “Refreshing Your Media.”  The green line moves a tiny bit then stops and is frozen.  I let it go for an hour–no movement.  I’ve tried removing the card (after turning the device off) replacing the card and turning the device back on.  Same thing. 

When I remove the card and turn the device back on without it, my internal memory is fine–although I did have trouble getting my computer to recognize the SansaFuze again after that–but I figured out what to do about that–so that is not a problem.

Any suggestions?

Corrupted song files


Wrong format ID3 tags

Check this FAQ.

 I think you may need to do the playlist on the internal drive.  Try that and see if that works.  If so, that’s the case. 

Also are the songs on the Fuze or just your computer?  I’m sure they have to be on the fuze or card to be on the playlist, not just the computer.

If the songs are just on the computer, put them on your card and then create a playlist.  I haven’t put any playlists on my card, but I have one that has just songs from my card and will load the playlist on the Fuze when I put the card in.  I have my Christmas card in right now and the playlist doesn’t show up because the songs aren’t on the fuze or card.

However, when I put the card with the songs in, the playlist shows up.
Message Edited by Dalaug234 on 12-09-2009 11:27 AM