Mediakit reports not enough space

Good afternoon!

I have a pair of SanDisk 1TB SSD Plus drives that were installed in one of my client’s 2012 Mac mini Server in a mirrored RAID.  I had Mac OS X 10.12 Sierra installed since it is the latest system to support a RAID configuration.

This worked fine for about a week.

The client saw the message “New software is available” and tried to install Mojave with disastrous results. Both drives have a partition map that is unreadable now.  They also show the capacity as 16k so they cannot be reformatted and I get the error "MediaKit reports not enough space on device for requested operation.”  

After extensive search online and spending an afternoon in Terminal I am still left with $400 worth of coasters.


Also tried Windows.  I actually built an old Dell just for this.  Anyway, ran the latest SanDisk Dashboard, and like many others, it did not recognize the drives.  Uninstall and install older version and they are recognized but I have all the options greyed out.