Media converter.exe has stopped working

I open the program and start uploading a video but it soon says “sansa media converter.exe has stopped working.” It worked for about two days, and it let me convert videos (mp4’s). Now every time I try to upload a video on my Sansa, it will only work for about 30 seconds and then it will say “sansa media converter.exe has stopped working” and all I can do is close the program.  Help!!

Try uninstalling and reinstalling it if you still have the installer.

Or just forget about it and get

Just go right for video4fuze. It converts more things in one step. For example, if you wanted to convert .flv, which seems to be the bulk of YouTube vids. you would need another program. like the free version of NCH Prism,  to convert the flash vid to an avi which you would then have to run through SMC. With video4fuze you just chuck in the .flv and a Fuze-ready avi comes out the other end

I haven’t tried it for images or playlists yet but it was designed for Fuze. Also get the latest version as it brings with it the support structure like Python and Nokia QT (not QuickTime I think) I got mine by googling up video4fuze

There isn’t by chance a video4view program out there is there?  SMC is giving me the same error.  I’m wondering if it is due to the size of the videos.  Uninstalling and reinstalling SMC doesn’t fix the problem.

I’ve actually found a reason to keep my SMC. The vid it prodouces is more generally (on my PC) useful than the video4fuze which vids only play on the Fuze

All I did with my problem is reinstall. It works with me. hope this works for you. 

Thanks Sansa Guru, this solved my problem!