m240 wont turn on anymore??

Alright, so I’ve had my Sansa for about a year and a half and have loved it and had no problems with it up until now.

I tried to plug it into the computer this morning to take off/add music to it, as per usual. It all went fine until I unplugged the MP3 from the computer. It went to the “Rebuilding Library” screen, but then shut off within 3 seconds. So I plugged it back in, and re-did everything a second time.

Now it’s doing the exact same thing. It’ll turn on fine, going to the “Sandisk” screen, and then the “Sansa, m240” screen. But then it does the whole “Rebuilding Library, please wait” and then fast shut off thing.

I’ve heard that I had to press a button to safely unhook my Sansa from the computer. I didn’t realize this, so I have always just unplugged it right away when it was done syncing music. Is there anyway to get my Sansa back up and running? Or do I have to go out and buy a new one?

Please help!

Thanks in advance!

Oooookkkkkkkkaaaaaaayyyyy will anyone help ?? XD

Is your player recognized by your PC when it’s connected?  If so, try formatting the player…

Nope, mine isn’ recongnized by my computer at all…I even tried plugging it in my friend’s PS3 and even the PS3 wouldn’t recognize it was plugged in O_O