lost music files

I’ve lost all my music files even though the Info button says that I have about 2GB of files on the clip. My USB setting had been at Auto, and I’ve tried setting it to MSC and MTP, but still don’t see any files. Any suggestions?

The easiest thing might be just to nuke it and start again in a mode you know. Assuming you have other copies of the files on your computer, the simplest thing would be to Format the unit, put it in MSC and send the 2GB over again. It will wipe off anything you put on the unit: Settings/System Settings/Format.  (It doesn’t affect the firmware.) 

If you want to keep looking, MTP and MSC are the only two places they’d be. Does “info” give you a number of songs, etc, or 0 ?

When you say “lost” do you mean:

  1. They don’t show up on the display.

  2. You can’t view them from your computer.

  3. would suggest they are not files the Clip can play. If your files are .m4a or .m4p or .aac  files from iTunes,  the Clip won’t show them because it can’t play them and it is pretending they don’t exist. 

  4.  may mean they somehow got hidden. If you are using Windows,  go into your Help and search for “Show hidden files and folders.” There’s a different path for that setting  in each version of Windows. Otherwise files sent over via MTP should be visible in MTP mode and files sent via MSC should be visible in MSC. 

Your computer setup would determine what Auto did. If your computer has Windows Media Player 10 or higher, Auto would go to MTP and your files should be visible there. If your computer has Windows player 9 or under (the original XP only had WMP 9), or if  you are on Apple or Linux, Auto would go to MSC. 

All I can suggest is, keep looking. Open any folder you can see from your computer and look inside; also right-click Properties to see if it’s empty or not.  Or on the display,  click down to Folders under Music, which is something like a Windows folder-and-files setup, and see if anything appears. 

Not sure if you’ve already done this but have you tried to plug this in on a different PC? Just to check if there’s a difference.