Ixpand usb 3.0 not working with Iphone 7


Need some help ! Just baught my Ixpand usb 3.0 so that I could clear up some storage space on my Iphone 7 (version 10.3.1) but it has proven to be a bit more complicated than I thaught.

I easily downloaded the Sandisk Ixpand app, but when ever I try to back up my photos it downloads a couple of photos (ex: 78 out of 441) and then the app automatically closes and re-opens without the complete back up.

I have tried numerous things:

  • Deleting the app and reinstalling - didn’t work.

  • Shutting off my iphone and turning it on again - didn’t work.

  • Downloaded the update for the Ixpand usb 3.0 - it poped up with the fact that it already was updated with the newest version available - so that didn’t help either.

I tried to use and back up files from an Ipad mini - could do that with no problems.

Tried then backing up a friends Iphone 6s and could qick and fast back up all her 3558 photos.

Anybody with same problem ? or idea for a solution ?

in setting do you have icloud photo library turned on? If so that could be the issue. Some of the images may not be stored on the phone itself and there could be something going on in the download process that is causing the issue. If icloud photo library is turned on try turning it off and see if you can transfer only the files that are stored locally on the phone. 

Hi drlucky

I’ve just checked it and my icloud photo library has been turned off all the time. Thanks for the tip though, would have been great if that was the issue (:

I have a similar issue to yours but, can I ask you, when this happens, " but when ever I try to back up my photos it downloads a couple of photos (ex: 78 out of 441) and then the app automatically closes and re-opens without the complete back up." do you see any error message on the screen? Mine crashes after every 20 photos or so, and then it says “failed to connect to iXpand drive”, which is obviously ironic because it _did _in fact connect, otherwise it couldn’t have backed up those 20 or so photos. 

Something is extremely buggy because I had to delete and reinstall the app, and force quit the app and restart the phone etc just to get _this _far ! 

The troubleshooting instructions within the app actually specify to _combine _switching off the phone and reinstalling the app and I hadn’t done that. So this time I tried 1. delete app 2. turn off phone 3. turn on phone 4. re-download app 5. insert iXpand device. I’m not holding my breath, but so far it has backed up 220 more photos than before without crashing. Let’s see how it goes. If this “fix” is stable, I will let you know and maybe you can try it. 

It’s kind of disappointing; relative to a USB, it’s a very expensive device and I would have expected it to just work, out of the box. Oh well. 

for the edification of anyone else who might come across this thread searching for an answer to this issue, I fixed this issue by deleting the ixpand app, turning off the phone, turning it on again and redownloading the app. Deleting the app and redownloading (without restarting the phone) didn’t work. And just restarting the phone without deleting and redownloading the app didn’t work. 

this issue being solved, I have to confess that the iXpand drive is the best money I ever spent since I bought an iphone. 

Now, if I could only work out why the phone says I have 22GB of photos, while the info pane for the iXpand drive says there is 20GB on the drive, in spite of the fact that the iXpand app said that my photos and videos were “fully backed up”…

I’ve got the EXACT problem. Sigh. I did “successfully” copy a few photos and videos to the usb drive, but the app keeps crashing and returns back to the home screen MANY times. I tried both copy manually and auto backup. Just found that it would be a little better to copy manually with a very few photos at a time. But you know that it’s so not user-friendly. I spent a whole night for reinstalling app, switching on and off the iPhone, searching solutions from the Internet. The battery has gone so quick, like using 10% in 5 minutes. I am just so disappointed for this untested product. And I can’t believe that it is from SanDisk. 

check first the icloud. Then try to install again Ixpand usb 3.0  app. then reboot the phone.