iXpand SecureAccess for mac

I have tried to install the software on my Mac but unfortunately it doesn’t work. It just says that it can’t be installed on this disk. Any thoughts?


The iXpand flash drive uses Secure Access V3.0 for file encryption, refer to the link provided to download the same:

Secure Access V3.0 download

Also use the same password that you created on the iXpand Sync App  for secure access when you are downloading the Secure Access on the Mac.

Hi there 

I too have recently purchased ixpand and am unable to install  secureacess v3 to my Mac …

keeps telling me cannot install to this disk …

installation is perfect on my iPad pro …

please advise 

are you running the secure access dmg from your mac of from the drive? The software needs to be on the ixpand itself not the computer HDD. 

I am installing from the .pkg file from the iXpand drive and I still get the error about how the SecureAccess v3.0 app cannot be installed on my disk.  I’ve got 43G space on the computer, which is a 2010 macBook Pro. What gives?

OK. I have figured it out, with the help of a chat guy.  There are steps missing from the documentation about installing the SecureAccess app.  In fact, none of the documentation on the iXpand drive contains anything about the installation of the secureaccess application on a Mac.  Here’s the crux of it.  The app must be installed on the iXpand drive itself, not the Macintosh Hard Disk.

Their instructions on accessing secure files on your Mac computer *start* with (to paraphrase) “Launch the SecureAccess… app and click next”.  Well… first, it doesn’t say that that app *will be* located in the root directory of the iXpand drive and second, it completely skips the part about running the app’s package installer and selecting the iXpand drive as the install destination.  I don’t think it’s necessarily intuitive that the app’s install location should be on the drive itself.  In retrospect, that makes sense, but I’m a computer scientist, and *I* didn’t intuitively get that at first.  So I think that a novice user might get stuck there, thinking the app will not install.  Why not have these details in the documentation?

Besides that, another deficiency of the documentation is that they claim the only way to fix an iPad-unrecognized iXpand drive is using an iOS 8 device or a Windows computer (neither of which I have, BTW).  Being a computer scientist, I had wanted to install my own encrypted disk image on the drive - ran into some issues - and had reformatted the drive using Apple Extended (journaled), which caused the drive to not be recognized by the iPad iXpand app.  Fine.  I messed up.  (Besides, as I found out, the .dmg format file isn’t usable on the iPad.)  But according to the documentation, I was screwed - stuck with a USB dongle that wouldn’t work on my iPad!  Well, the documentation is defficient, because you can fix this issue on a Mac computer.  You simply have to run Disk Utility and reformat the drive using MS-DOS FAT format.  Viola!  It worked.  Please update the SanDisk documentation to reflect this fix.

While I’m on a rant…

I put a bunch of files in the vault from my computer in their own directory structure.  I was shocked to find out that to access these files on the iPad, I had to *move* them out of my directory structure (and decrypt them) and put them unsecured on the iXpand drive.  Then my only option to re-secure the files was to put them in the secure vault’s *root* directory!  I couldn’t put them back in the directory they came from!

Don’t get me wrong. I appreciate the ability to maintain secure files and swap them back and forth from the computer to the iPad.  This is the only method to do this I’m aware of without going through the internet, so it is useful.  But this interface has, in my opinion, quite a ways to go.

And don’t get me started on the mac application’s interface…

1 Like